Instant Hotspot not working for Mac Book Pro

Forum
macOS & Mac Apps

Hello,
Ever since yosemite I have not been able to use my iPhone as a hotspot. Bluetooth and wireless are enabled on both and hotspot is enabled on the iPhone. But it does not show up in the wireless dropdown menu as an option to connect. I know the hot spot feature works because I can connect to it from with Windows in Boot Camp on the same machine. Is there an accessibility issue here or is something not set up correctly? I have the same iCloud account set up on both machines and they are even on the same network. At a loss at this point....thanks.

Options

Comments

Submitted by Chris on Sunday, March 15, 2015

I am having the same issue. Instant hotspot doesn'twork as advertised. I am using a 2013 Macbook Air. When I go into the wi-fi menu, I do not see my iPhone network unless I manually turn on Personal Hotspot. What's up with this? Is this an accessibility issue?

Submitted by Tyler on Sunday, March 15, 2015

Member of the AppleVis Editorial Team

When navigating through the wifi status menu, Voiceover doesn't speak the name of an iPhone. Instead, move up and down the list and press VO ww to get the spelling of each option. Select the one that spells the name of your iPhone, even though it might speak a different option when just going by word.

Submitted by Chris on Sunday, March 15, 2015

Hi.

That doesn't seem to work. I tried to spell everything out in the wi-fi list with VO w w and it just spells the wi-fi networks. When I turn on Personal Hotspot, my iPhone shows up as CHris's iPhone, but when I hit VO space, it asks me to enter the password. What exactly is the bug here? I'm confused. HOw is this instant hotspot if it just exhibits the same behavior as it did before iOS 8? I'm using an iPhone 5s.

Submitted by KE7ZUM on Monday, March 16, 2015

I can't remember if I posted this, but I just today submitted to apple using the feed back form so let's hope that they actually listen for those of us using Yosemite of all flavors.

Submitted by Cliff on Monday, March 16, 2015

Hi! I had this exact problem a few days ago. For me, what helped was to drop the VO keys and only use up and down arrows in the WiFi menu. Seems to me that using VO+arrow keys in the menubars sometimes will produce different or lacking options then if you're using only the arrow keys... Haven't allways been able to reproduce this behaviour, but if I'm VO-arrowing in a menu or in the menu extras, and I find something is missing, my first go-to-solution is usually to drop the VO keys and see if something else shows up in the menu.
Hope this helps somehow... :)