Insertion point is inaccessible on web pages in El-Capitan

Forum
macOS & Mac Apps

Hello!
Since updating to OS X El-Capitan I'm unable to move insertion point inside a textfield and have to edit text elsewhere. Can somebody help please.
P.S. Even now, when typing this post on Applevis, I'm experiencing the same issue

Options

Comments

Submitted by Felix on Friday, November 6, 2015

Tried a clean install of the OS but to no avail. Apple Accessibility said in their reply they could not reproduce the issue. Seems there's no any viable solution for now

Submitted by Isaac Hebert (not verified) on Friday, November 6, 2015

I just tried this as well but when I use the left or right arrow keys to move character by character and press the backspace key to delete one character it does it with no problem.

Submitted by Isaac Hebert (not verified) on Friday, November 6, 2015

I just tried editing text before posting this reply that I am about to post regarding editing text on the mac with AL capitan and I am not having problems here.

Submitted by John W. hess on Friday, November 6, 2015

Good morning. I have tried editing in a search box as well as this post and it works well. Not sure what you are having this problem? If you do find the solution please post it. Thanks.

Submitted by Ekaj on Friday, November 6, 2015

I have had this problem too, but only on certain pages it seems. For instance, http://www.easychirp.com seems to have this issue a lot. I don't know why though, because that site is otherwise very accessible. I tried tabbing and then shift-tabbing back to the text field, and it has worked for me. It must be an issue with coding or something. But then again this issue never popped up for me prior to El Capitan, so something must've changed. These random bugs certainly are interesting though.

Submitted by Felix on Friday, November 13, 2015

I thought the problem might have originated from a new "window spots" navigation mode, so I tried to disable it, but have no idea how to do it. Is it possible to achieve this somewhere in accessibility settings?

Submitted by splyt on Friday, November 13, 2015

Make sure quick nav is off (left right arrows pressed).
If quick navigation is on you'll have issues.

Submitted by Jennifer M. on Thursday, November 26, 2015

Does anyone know if there a key command to jump to the next edit field when using safari?
Thank you.

Submitted by Ekaj on Sunday, November 29, 2015

In response to the previous comment, just press the letter F when QuickNav is on. That should get you to the next edit field and Shift-F does the reverse. Hth.

Submitted by Felix on Wednesday, December 16, 2015

OS X 10.11.2, the issue with text fields is still present. Alas, Apple did not address it in the latest update.