How to turn off language detection on Mac?

Forum
macOS and Mac Apps

Hi, I'm not sure if this is possible as I've searched VoiceOver utility but thought I'd ask just in case I'm missing anything.

Is it possible to turn off the language detection on Mac like you can on IOS.

I have a Spanish bank account and when I use the bank website, VO somehow recognises that it's a Spanish site and switches to a Spanish voice. What doesn't make sense though is that the site is set to English and VO is actually reading the words correctly in English but with a Spanish accent which makes it very difficult to understand. The only way I can understand the text is by reading the words a character at a time as VO reads the singular letters in English. It's quite bizarre and a real inconvenience.

The only thing I can assume is that it's some sort of language detection and my hope that by turning it off (if it's even possible to do so) the problem may be fixed.

Thanks for any help
Nathan

Options

Comments

Submitted by Quinton Williams on Thursday, April 22, 2021

I have a solution, assuming you're still having the problem. When you go through the voice options in the rotor, so with command+vo+arros, voiceover will most-likely say"automatically detect based on language". You can go down to the voice you want and it will always use that specific voice of choice and it will always use that specific voice. I hope this helps :).
Best,
Quinton

Submitted by Stoo on Friday, November 26, 2021

Hi, I'm having the same problem as the original poster.

Setting up my new Macbook M1 Pro and my Voiceover language is set to UK English as default.
I have no other languages set as far as I can tell.

Every time Voiceover reads song titles or artists in Apple Music that it thinks are Non-English, it reads them in a different language and it's impossible to tell what is being said.

Exactly as per the original post.

I can't use the solution given in the comments previously, as I have no way of changing the language in the rota.

Is there a way of fixing this, or can someone tell me how to add languages to the rota?

Thanks in advance, Stu.

In case anyone else wants a solution, in order to change language you need to press VO, Command, Shift and either right or left arrow.

Langauges aren't part of rota gestures if using a trackpad as far as I can tell

This solution works however and allows the option to change the default language, thus fixing the original problem.

Submitted by kolanos on Tuesday, March 15, 2022

Your solution did the trick, much appreciated.