How to disable ”Actions available” prompt in Pages?

Forum
macOS & Mac Apps

Hello,
I'm not sure if anyone asked this. When switching from another app to Pages or from a Pages document to another, I get this prompt: ”actions available Format text quickly by VoiceOver jumping to the formatter”. Is there a way to disable it? I find it quite frustrating, because I work with a Braille display and when this alert appears, I lose focus and I have to re-read lines.
Hopefully, there is a solution to this.
Thank you in advance,
Alexandra

Options

Comments

Submitted by Bruce Harrell on Thursday, June 17, 2021

If you never use that feature in pages and if you don't want it spoken, Here's what I would do.

press vo-shift-c right after you hear your hated phrase spoken. Then, go to the vo utility (vo-f8), interact with speech in the table (meaning go into the table by pressing vo-shift-down arrow, then arrow down to speech, and uninteract with the table by pressing vo-shift-up arrow. Then, vo-right arrow to the pronunciation tab, hit vo-space bar, go to the add button, hit vo-space bar, and in the first edit box, press vo-v to paste what you captured back when you pressed vo-shift-c.

After that, go to the next edit box and press any character that doesn't get spoken (space, for example). This will set up the dictionary so that when voiceover encounters your hated phrase, it will speak the silent character instead, and as we know, smile, silence is silence.

Again, if you did everything correctly, once the new pronunciation you've created is finished, whenever pages opens and voiceover encounters the hated phrase, now it should simply stay silent.

Smile. Good luck!

Bruce

Submitted by Alexandra Moldovan on Thursday, June 17, 2021

Hello,
I did it, but nothing happened. I see that, after I copy it with VO Shift C, it doesn't pause after ”actions available”. Maybe there's a hidden character there, so it doesn't get copied. Is this the problem? If I paste it here, it does the same: actions available Format text quickly by VoiceOver jumping to the formatter. It should say: actions available. Format text quickly by VoiceOver jumping to the formatter. I hope I made myself understood. Is there other possibility to silence it?
Thank you.
Alexandra

Submitted by Alexandra Moldovan on Thursday, June 17, 2021

And I couldn't paste with command V, only by using Vo+Shift+M and choosing paste.

Submitted by Bruce Harrell on Thursday, June 17, 2021

I'm thinking the announced phrase must not be text on the screen but is instead some sort of announcement or hint, so you might want to try this:

Go to voiceover utility>verbosity and experiment with announcements, starting with turning them off. If after turning off announcements, the pages app stops getting that phrase read by voiceover, you know you are dealing with a voiceover announcement problem. The trick then is to figure out how to turn off only that single announcement when in pages. Since it only occurs inside Pages, you might want to create an activity just for pages and set the verbosity>announcements to the desired setting.

If turning off announcements doesn't stop the phrase being read, try voiceover utility>verbosity>hints and turning off hints. If after turning off hints the phrase is no longer spoken, you know you are dealing with a voiceover hint. Then the trick is to figure out how to turn off only that voiceover hint when in the Pages app and to create a Pages activity with that hint setting.

Incidentally, activities are at the bottom of the voiceover utility table.

Good luck!

Bruce

Submitted by Alexandra Moldovan on Thursday, June 17, 2021

It was a hint and a custom actions announcement. Thanks for your advice, it really helped.