Help, the ‘K’ and ‘L’ keys are not working when VoiceOver is enabled

Forum
macOS & Mac Apps

Hello there,

a user new to using the mac was fiddling around with his macbook air the other day, and managed to do something which has caused all keys but the k and the l key not to work. I.E during entering the password and with voiceover off the K key and the L key work just fine, but turn on voiceover and they won't work at all.
Could it be that the vo that is ctrl option are locked? but then how and why do other keys work.

Any assistance regarding the matter is welcome.
Thanks!

Options

Comments

Submitted by Tyler on Wednesday, February 22, 2017

Is he using the caps-lock key as the Voiceover modifier? There is a longstanding bug that causes the Voiceover modifier to lock whenever a password field is in focus when using the caps-lock key. Try pressing the caps-lock key once to unlock it and enter the password.

If this is not the problem or to rule it out as a potential factor, you can set the Voiceover modifier to the control and option key only. This is under the general category in Voiceover Utility.

Another thing you can try is to check if the control option lock is on by pressing VO semicolon. This mode will cause any key on the keyboard to be treated as if the control option keys were held down.

HTH

Hi,

The Keys work just fine during the password entry, its after the system is on that they don't

Is there a way to enable or disable the ctrl option lock? I am thinking he must have enabled it if such a thing is possible to do. and if yes, how would one go about disabling that

he is using the ctrl option keys instead of the caps lock.
I suppose just setting the modifier to capslock should fix that if that indeed is the issue that's causing this.

Thanks again,T Dog.

Submitted by Justin on Wednesday, February 22, 2017

Yes,
To enable the CTRL+option lock, press the CTRL option keys or caps lock key whichever is set or both. Then hit the semicolon key while modifier is held down.

Submitted by falcon wings on Thursday, February 23, 2017

In reply to by Justin

Hi and thank you for the reply

However, my question was more towards if there was a way to disable the thing. I.E right now, say the user is in spotlight, they will be able to use all the keys to write accept the k and the l keys,and a few others.
These keys that don't work in spotlight and other places,work just fine during password entry and when voiceover is off.

Is there a way to set all the voiceover settings to defaults,then? if nothing works I guess we could try that, or a reset of all the settings if that's possible.

Thanks.

Submitted by Justin on Thursday, February 23, 2017

I'm not exactly if there's an exact way to reset vo settings back to defaults. If there is, I don't exactly remember what it is. Make CTRL option lock is turned off after the password is entered and is logged in. There is no way of disabling it. Just turn it off just like turning the lock on. That should solve your issue. Otherwise I can't help anymore than that. I've never seen this issue before in my experience of owning a mac.

Submitted by Tyler on Thursday, February 23, 2017

To reset all Voiceover preferences, open Voiceover Utility and choose file>reset all Voiceover preferences.

HTH