Has anybody else encountered a problem with VoiceOver speech output on the Mac when using a bluetooth headset in multipoint mode

macOS and Mac Apps

I am extremely interested in learning if anybody else has seen similar issues to those I am about to describe. And, if so, have found a solution.

My scenario is that I am using a pair of AfterShokz Trekz in multipoint mode to pair simultaneously to both my iPhone and MacBook.

For the most part things work as expected; and audio switches fairly seamlessly between the 2 devices and the Trekz.

However, on a regular basis, I find that this use case can result in VoiceOver speech output stopping on my MacBook .

When this occurs, regular audio and system sound effects will continue to play as normal. However, there is no speech output from VoiceOver.

When in this state, I know for sure that VoiceOver is enabled; audio is not muted; and the volume level is where it should be.

I Have a keyboard shortcut configured to switch the default audio output location between the Trekz and Internal speakers. When I use this when VoiceOver speech output is not working, the output location correctly switches, but it does not resolve the problem.

I have another shortcut to disconnect the Trekz. Using this does not resolve the problem, although the Trekz do audibly confirm that they have been disconnected. Neither does turning the Trekz off.

Using Command+FN5 or Siri to toggle VoiceOver off and back on does not resolve the problem either. When trying this, there is no feedback from VoiceOver to confirm the change in status of VoiceOver, but the change in system sound effects does confirm that VoiceOver is being toggled off and on.

I have had somebody check when this problem occurs, and they confirm that VoiceOver output in the VoiceOver Utility is set correctly.

So, when in this state, my MacBook is essentially unusable and the only solution I have found is to hold down the power button to power down the MacBook; and then restart it. Once restarted, VoiceOver returns to working as expected.

This problem typically occurs 2-3 times a day with my usual use case.

This problem does not occur spontaneously, in that VoiceOver speech output will not stop when I am in the middle of doing something. Typically, I might wake my MacBook to find it in this state; or find it like this after briefly being far enough away from the MacBook for the connection with my Trekz to have dropped. On a few occasions, this has happened when the Trekz have been turned off after use, but not manually disconnected from the MacBook beforehand (which in theory should not be necessary, anyway)

What I have yet to find is a consistent pattern to when I will see this problem. Although it has happened in the scenarios mentioned above, it does not happen every time that they occur.

For now, I am having to manually disconnect my Trekz every time that I stop using the MacBook; even when it's simply to take a few minutes break.

My use case won't be unique, so I am somewhat surprised that searching finds nobody else reporting anything similar (particularly when I see this problem so regularly).

This is running the latest public release of macOS Sierra, but is not new in this release.

So, does anybody have any suggestions for possible causes or solutions?



Submitted by Dalia on Thursday, April 20, 2017

Hey Tim,

I appreciate the suggestion, but it's not the cause here.

Do please keep any suggestions coming, though. And, anybody else please feel free to throw in your own ideas, as this is so darn frustrating that I am happy to hear just about anything that might explain and resolve this behavior

Submitted by Justin on Thursday, April 20, 2017

I'd give er a go. Try using only one BT device. what i mean is connect it to the Mac or the iPhone, not both at the same time. Perhaps BT on one device is causing the other device, the mac, to have issues. I haven't seen this in the latest oS releases, but back somewhere in Mountain Lion, or maybe Yosemite, I had this happen, VO would suddenly stop speaking and you'd either have to disconnect or restart VO.

Submitted by Dalia on Thursday, April 20, 2017

Thanks Justin, but neither disconnecting the headset or toggling VoiceOver will restore speech output when this problem occurs.

As for using a different headset with each device, I have reverted to this at times, but keep coming back to the multipoint setup because when it's working as it should, it's exactly what I want.

Submitted by Voracious P. Brain on Friday, April 21, 2017

Reminds me a bit of what happens when the Windows playback device changes while using NVDA: NVDA won't switch with Windows, even though it's set to play through the default device. However, restarting NVDA fixes that one. You probably know already that VO can be set to use a specified audio device. Perhaps adding an automator action to do that at the same time you're telling it to switch audio devices...

Submitted by Dalia on Friday, April 21, 2017

Thanks for the suggestions.

I have actually had somebody check the setting for VoiceOver output when this problem has been present, and it's been set to the system default. So, in theory, it should be working as expected.

I did look into creating an AppleScript which would toggle this in the hope that it would resolve things when VoiceOver output is in this 'broken' state, but had no success. I have not used Automator, but will follow your suggestion and see if I can create a output toggle with that.

Submitted by Oliver Kennett on Tuesday, June 11, 2019

Hi, before I start, I'm afraid I have no solution here, just the same issue though I'm using Beats X with the apple own W1 chip in it. After a time of inactivity voiceover goes quiet though there are the sounds. I'm just wondering if it is a multi-point issue... Possibly my Beats, when left alone for too long, are trying to connect to my phone or my watch. I know this doesn't really cover your issue... Are you still suffering from this problem? Your setup, when it works, sounds perfect to me. I was looking for a way to use mac and an iPad to run some gaming sessions. Keeping the two seperate sounds grand meaning I can have stat blocks on the ipad whilst keeping track of initiative on mac as well as hit points. I run music via airplay from Itunes and feed dice rolling sounds through my MBA speakers whilst asking voiceover to output to my bluetooth headphones. It is possible that the complexity of this setup is to blame, but, wehn you're dropping over a grand on a machine and using apple created products with apple created product, you kinda expect them to work.

Submitted by James L on Sunday, September 29, 2019

Has Anyone found a solution?
I'm on Mojave, and I often lose speech when using Bluetooth.
When I press vo_arrrow, I can hear the navigation sounds through the Bluetooth, but but there's no speech.

Submitted by John on Tuesday, November 5, 2019

In reply to by James L

I experience similar symptoms. When using Blue Tooth headphones I will frequently lose the speech output of Voice Over in macOs. The underlying Voice over sound effects are still produced while typing with no speech. I first encountered this issue with AirPods initially paired with my iPhone and exposed to my macOS device through iCloud sync. I have since tried other configurations, such as Trex Titanium paired solely with my macOS device and over the last few days with AirPods Pro.

When I first began experiencing the issue I would forcefully restart my device. However I have subsequently found that using VO+F5 4 times with a 1 second pause between presses will cause Voice Over to restart in a usable state. I usually have several ssh sessions open to remote systems so avoiding the forced restart has reduced some of the frustration.