Hard drive error, importing from Time Machine to new drive and misreporting of drive capacity

Forum
macOS & Mac Apps

Hi,

Recently when trying to upgrade to El Capitan my Macbook Pro told me it couldn't do this because there were problems with the hard drive which couldn't be fixed. I took it to the Apple store and they confirmed the drive was failing and replaced my 750 gb drive with a new 1.5 tb one with El Capitan installed. I got my machine back yesterday and as part of the setup process told it to import my backed up data from Time Machine on an external drive. Everything is functioning fine but out of curiosity I went to finder and "get info" on the hard drive and it tells me the capacity is 750 gb, not the 1.5 tb I'm now supposed to have. More alarmingly, again out of curiosity I went to disc utility and in there it says about the hard drive "S.M.A.R.T. status: Failing. I can't imagine how, but my gut instinct is wondering whether importing my data has somehow caused the failure and problem with drive capacity as I'm sure Apple would have checked the drive after installing it. After a little googling I saw something about problems importing Time Machine backups to a drive of different capacity to the old one but I didn't look much and didn't really understand it at first glance. I'll have to go back to the Apple store but I'm just wondering if this rings any bells with anyone. Has anyone ever had these problems or got any ideas what's going on? Could something in my data cause a problem like this? I have Clamxav which isn't flagging any viruses. Does anyone know anything about importing Time Machine backups which were originally on a different size disc? Seems frustrating if it is true this is problematic as surely a lot of the time the use of Time Machine is when switching to a new Mac and a lot of that time the drive capacities would be different. Everything functioing fine at the moment but it's strange about the drive capacity and worrying about the failing status.

Options

Comments

Submitted by wheelysneakycat on Wednesday, November 25, 2015

An additional bit of info. Checking in App Store for any updates to my apps weird things are happening. It's showing the Os El Capitan as downloaded and an install button which is dimmed. Before the hard drive got replaced I had downloaded but not installed El Capitan. Also in App Store there are some apps listed with an install button as if I haven't installed them but they are actually installed and running. It feels like in some ways the old OS is running with my apps etc in the same state they were in before and the drive capacity as it was, yet in About This Mac it says I'm running OS 10.11 and the machine is meant to have a bigger drive in it. Confusing. Plus this issue about S.M.A.R.T. status: Failing in Disc Utility.