Fixing VMware Fusion sound latency on a Windows 10 guest

Forum
macOS & Mac Apps

Hi
Recently, I made a new virtual machine running Windows 10. I've previously followed Bryan Smart's guide on fixing VMware Fusion sound latency issues, but those instructions don't seem to apply to VM's running Windows 10. Have you guys found any solutions to reduce audio latency?

Best
Malthe

Options

Comments

Submitted by jack on Friday, February 1, 2019

What version of Fusion are you running? I think at least version 10 is required, maybe 11. And you're using the sound.buffertime vmx entry, right?

Submitted by Malthe on Friday, February 1, 2019

Hi
Thanks for your reply! I run 11.0.2, so I should be good on that front. Do you use the HDaudio device, and then tweak it with sound.bufferTime in the VMX? Is that the only entry you tweaked?
I tried setting it to 30, but it still didn't feel as snappy as my 7 VM.

Best
Malthe

Submitted by Igna Triay on Saturday, February 2, 2019

i have a windows 10 vertual machine and its not delaying sound as far as i can tell. Nvda takes some seconds to load, but then again, i have a lot of addons

Submitted by Malthe on Sunday, February 3, 2019

Hi
The delay for me is fairly small, but bigger than on 7. I tried setting sound.bufferTime in the vmx to 20, which helps a bit, and I also turned off hardware acceleration in display settings. The delay is les now. My MBP is from 2013 though, so it's not the newest on the block. This is probably also a factor.

Best
Malthe

Submitted by Chris Bruinenberg on Thursday, November 7, 2019

Hi all.
How do i change the sound buffer?
I know you open the vmx file, but where do i add the line?
Thanks for any help

Submitted by Malthe on Thursday, November 7, 2019

Hi
I don't think it matters where you add the line. If I remember right, I have it right at the end.
You can also group it together with the other sound entries if you prefer, for organising's sake.

Submitted by Steve Sawczyn on Saturday, November 30, 2019

Hi, I'm running Windows 10 on VMware Fusion 11.5 and am noticing that sound stutters quite a bit. I tried adding the sound.buffertime entry, but it doesn't seem to make a difference regardless of what value I use. Does anyone know if this parameter has changed to something else in 11.5, or is there something else I should do?

Submitted by Malthe on Tuesday, December 10, 2019

Hi
Did anyone manage to resolve this?

Best
Malthe

Submitted by Steve Sawczyn on Tuesday, December 10, 2019

In reply to by Malthe

So one discovery I made is that the sound.buffertime setting seems to work much more reliably if a 32-bit version of Windows is installed VS a 64-bit. I set up my virtual machine, this time using 32-bit Windows and the delay is far less. I'm still adjusting the sound.buffertime setting to find the optimal number for my hardware, but switching to 32-bit made a huge difference for me.