external hd problems

macOS & Mac Apps

Hi all. Long story short, my time machien ahs been acting strange thought of erasing, then starting over with a fresh hd. This is a three tb sigate external connect I think fire wire, it's not a standard usb port. However first it's now showing as mounted, now it is mounted but it won't let me erase volume failed, media kick won't support the space or something strange like that. Is there a third party app someone can help me find that just fixes this? I just want to keep using it, don't want to spend more money if i can't.



Submitted by KE7ZUM on Wednesday, November 5, 2014

Try disk utility and do a file verify with the recovery consoul. See if that works. if not then maybe there is something physically wrong with the hard drive, I really hope not.

Submitted by dvdmth on Wednesday, November 5, 2014

Club AppleVis Member

On a couple of occasions, I've had issues with my external USB hard drive, and each time it happened, I was able to get it working again by disconnecting and reconnecting it. Once I had to power it down, meaning unplug it, then power it back up before it worked properly, so that's something else to try.

On two occasions over the years, I had an external drive enclosure fail after a power failure. The drive itself was fine, but the enclosure it was in quit working. I have a technically savvy person in my household who helped me diagnose the issue each time that happened. After the second time, I got an uninterruptible power supply (UPS) so that future power outages won't cause this problem.

Submitted by KE7ZUM on Wednesday, November 5, 2014

A ups could work but try this in the following order

  1. boot in to the recovery consoul and repair permissions and very your time machine drive.
  2. check all connections and make sure they are good. Do what the other poster suggested.
  3. make sure the drive is not making any odd noises. if it is, it's probably physically broken.

Good luck.

Submitted by Siobhan on Wednesday, November 5, 2014

Ok I do have a brain in my head. lol. Seriously, I've tried verifying, it won't verify and it won't disc repair, and of course erase either. I really justhave backups on this thing, so I am not losing to much. I've googled and found I can use the command line, but it looks a little tricky for me, not impossible just, tricky. I'd rather not have to spend money, so is there anything else I cna do if this console thing doesn't work? I've heard of using the fsck but I'm guessing there's no speech for me to do that and no sightedhelp I can ask, without a lot of what did you do, type of questions. I ejected ti propperly and when it comes up it shows liek things are ok when it mounts. I'd just rather try to reformatt and have a great hd. I got it formatted for the mac, so i plugged it in and played so to speak maybe that was my error. I did see it was mac osx journaled. ugh just wish I could catch a brake. thanks both of you dpd you especially for tryingto pullme out of the tech dumpster i've fallen into. thank you both.

Submitted by KE7ZUM on Thursday, November 6, 2014

  1. Hold down cmd R at boot up. 2 after 30 seconds lift the key stroke and start voice over.
  2. Go to disk utility
  3. go to the drive you want to test
  4. Go to repair and hit vo space on it. Now wait in my case about an hour.
  5. When you see no progress bar in the window, and it's hidden so look for that, quit disk utility and restart.

Good luck.

Submitted by Siobhan on Thursday, November 6, 2014

You did it, thank you. Now this one is one where you have to plug it in to start it, there's no switch. so I don't know how to prevent this from happening again, except just keep ti plugged in, shut off the mac, unplug then start it again. i know a bit crazy, but was glad I didn't need to lose anything. I was ready to of course. Thank you very much, I can't blieve I didn't see the stupid speech thing, silly windows fears. :)

Submitted by KE7ZUM on Thursday, November 6, 2014

Glad you got it fixed. My elements has no switch but it does not have that issue. Hmm. Beeing that I have never used, nor can I use firewire I am of no help here lol!

Good luck.