Changing output of VO when using Mixtrack Pro II

Forum
macOS and Mac Apps

Hi,

Recently I've started using djay pro and the controller I'm using is the Mixtrack Pro II. The controller has a built-in sound card and channels 1-2 are the master output, and channels 3-4 are the pre-queuing or headphones. The problem I'm having is I can't seem to get VoiceOver to come through my headphones, channels 3-4.

If I change the main output in system preferences, it automatically goes through the master output and there is no setting to change this. It's the same if I change the output for just VoiceOver in VoiceOver utility. For now, I have the outputs in djay pro set correctly and VO coming through my Mac speakers, which is fine, it'd just be easier if it was coming through my headphones along with the track I'm queuing up.

Is there any way to do this?

Cheers for any help.

Options

Comments

Submitted by peter on Thursday, September 3, 2015

You might want to ask your question on the midimag list. This is an e-mail forum of blind musicians, producers, and performers. They are very helpful and friendly.

To subscribe, send an e-mail to:
midimag-subscribe@midimag.org

Send a short note introducing yourself and your question.

Hope that helps.

--Pete

Submitted by Callum on Thursday, September 3, 2015

I asked on the Midimag mailing list and I found a solution! Someone mentioned audio Hijack, however I wasn’t sure about it as I think you have to pay for it. I came across a similar extension though called Soundflower. All I had to do after installing Soundflower was to connect my Mixtrack Pro, then on the 2 channel Soundflower option, set channel one on Soundflower to channel 3 of the Mixtrack Pro, and channel 2 on Soundflower to channel 4 of the Mixtrack pro. Once that is done, I then just changed VO’s output to Soundflower and it came through just fine.
Yes, I know this is a bit complicated, so feel free to contact me if anyone needs me to go through that a bit clearer.

One more thing to mention, if you do try this, make sure you set VO output back to the built-in output or whichever speakers you normally use before unplugging the mixer Soundflower is routed to, otherwise you'll lose speech. I made that mistake and had to get sighted help to get VO back.

Submitted by Callum on Saturday, October 31, 2015

Hi,

If you look at my previous comment on this post which I left a while ago, I explain that I found a solution for what I wanted to do by using SoundFlower. This worked fine until I updated my Mac to OS X El Capitan, as SoundFlower isn't compatible with it. There is a beta version which apparently works with OS X El Capitan, but I tried it and couldn't get it to work, then I found that you need another app to install it properly and clear off the old drivers and install the new ones etc, and it just seems a lot of hassle.
So basically, I'm now back to my original question, does anyone know another way I can route VoiceOver through channels 3 and 4 of my mixer? I did come across an app in the Mac app store called Audio Switcher which looked good, but it's completely inaccessible.

Cheers,

Callum.

Submitted by Andrew on Monday, November 16, 2015

This might be a non-solution, but I just tell DJay to pre-cue from my mac. I don't notice any lag at all and it works just fine while still using the controller. Maybe try that and see if you have any issues.

Submitted by Callum on Monday, November 16, 2015

Can't believe I didn't think of that!!! I'll give that a go, thanks very much.