Browsing amazon with safari on the mac

Forum
macOS & Mac Apps

Hi,
I'm not a newbie by any stretch of the imagination. I should have asked this question when I started having trouble browsing amazon on my mac with safari a long time ago. But I've always just settled for the use of the iOS app instead. But now that I have a need to use it on my mac, I'm kind of stuck. Anyway, what's happening is when I search for something, and move by heading, then arrow over, or even click on a result, it keeps bringing up this stupid incessant web popup dialogue with reviews and stuff. And when I hit close (on the web dialogue box, not close on the safari window), it just pops right back up again. Has anyone been able to use amazon smoothly with safari without these silly review popups? If so, is there something special you did, ie a mobile version of the amazon site that I should know about?
Thanks for your help.

Options

Comments

Submitted by Herbie Allen on Sunday, October 25, 2020

What I do is go to the end of the dialog and click on the customer review. I then use button navigation to go backwards to the first add to cart button.

Submitted by Bruce Harrell on Sunday, October 25, 2020

Hi. I use both the IOS app and the Mac app. They are both very annoying. It took me a lot of struggling with the limitations for the VoiceOver user that these apps created, but I finally figured out the things to do and the things to avoid doing. I do it so automatically now I'd have to think a while before I could outline the steps. In the meantime, what you can do is memorize heading numbers that are good and that are bad and avoid the ones that are bad. Memorizing should also include how many heading to skip forward at various points in the process. Also, going past the one you want to the next heading and then moving backwards to get the info you seek. Last, use the item chooser wherever possible. It saves a lot of time and trouble.
I hope this helps.

Bruce

Submitted by Greg Wocher on Sunday, October 25, 2020

Hello,
There is a way to solve this. Open up your VoiceOver settings with VO plus F8. Once in here choose the navigation category. Move until you hear a pop up button about the mouse pointer. Open up this pop up and choose ignores VoiceOver cursor. Once you do this, this should solve your issue.

Greg Wocher

Submitted by LaBoheme on Monday, October 26, 2020

let me guess, you make a search, then you navigate by heading using the arrow key of your keyboard?

when you search, especially the first search, the quick nav mode is mysteriously turned off, if it is not off already, that's why you're having trouble. press the left + the right arrows to turn quick nav back on.

Submitted by chris R on Monday, October 26, 2020

It is because when cited people hover over some elements with the mouse it brings up a dialogue, and in normal Voice Over usage the mouse pointer follows the Voice Over cursor so you're basically emulating this.
The way I have solved this is I have created a separate activity for Amazon in which I have disabled all cursor TRACKING from the navigation settings so the only cursor moving is the Voice Over cursor
you can also toggle this by using VO + shift + F3.
The only problem then is you have to remember to synchronise the cursors when you want to type in a text field.
No doubt having things appearing when you hover over elements is most visually pleasing for your average Amazon user but it is a hell of a nightmare for Voice Over users!

Submitted by Maldalain on Monday, October 26, 2020

I switch off JAVA in the Developer menu inSafari. This should solve your problem. When you are prceeding with the purchase, switch the JAVA plugin back on.

Submitted by honest nan on Tuesday, October 27, 2020

To get out of the reviews mess, I have always hit shift H several times to move back to a heading I'm looking for. But, now that I know about the toggle for cursor tracking mentioned earlier, I will use that, instead.