backup and sync by Google is being funny on my Mac with Catalina

macOS and Mac Apps

Hi all, I have a problem to report a problem with Backup and Sync by Google on my macintosh, the sole app I use to do Google Drive stuff. I can't get it to show shared folders, and the shared folders I do see it's not showing the latest files and such. I can't find the sync options, and it won't sync. I tried everything I knew what to do, including but not limited to, trying to force close everything but Finder was in the way. Then I tried throwing it in the trash, but oh no, it was open! !!! Then I tried to find a more button and open the thing, but oh no, Voiceover gave me trouble. The cursor was frozen or not there, one of those. What should I do next? Thanks.



Submitted by Daniel Angus MacDonald on Friday, March 27, 2020


though I'm not answering your question, I am wondering how you download this app. for me, the download button does not work in Safari in Catalina. help would be nice, as I am running out of storage in my google account, and I need to get google backup and sink working so I can deleete files.
thank you,

Submitted by Tyler on Friday, March 27, 2020

Member of the AppleVis Editorial Team

macOS Catalina changes the way apps access user data, requiring user permission to manipulate files and folders. I don't use Google Backup and Sync, but this was the case for me with DropBox. Did you check the window chooser and application chooser menus for permission requests?

If there are none, you can manually allow an app to access your data by going to System Preferences > Security & Privacy, selecting the privacy tab, and checking if Backup and Sync is allowed to access, "Files and folders," or, "full disk access." Specific entitlements depend on the app, so you may want to check the documentation to see what kind of access is required and the privacy implications of granting such access.


Submitted by Daniel Angus MacDonald on Friday, April 3, 2020

hey all,

I got backup and synk working. turns out there are terms to agree to, in a not so usible window. I press the download link, and am immage showed up. then I had to interact with that immage, and, finally, the button to agree to the terms showed up. thanks for all your help,