Automatic Zoom announcements on Mac can be disabled

Forum
macOS & Mac Apps

For quite some time, I've found Zoom's automatic announcements such as chat messages, who enters or leaves the meeting, or who is sharing his or her screen to be quite annoying. Most of these announcements occurred especially when I would command-tab away from the main Zoom window to check on another application. I could never find a way to disable these unwanted announcements. Well, while exploring Zoom settings with a friend, we discovered that there is a section of the accessibility settings in Zoom called "Screen reader alerts." There are alerts arranged in a table that you can uncheck if you don't want Zoom to announce various events automatically using the system voice. I was so thrilled that we found these settings as I know this will make Zoom even more enjoyable for me to use. As a side note, I also learned that command+2 will announce the name of the current speaker. I'll definitely make use of that command during meetings full of people I don't know. I don't know if these features are new, but I'm running Zoom version 5.3. I just thought I would post this here since I know this has been a topic of discussion in the past.

Options

Comments

Submitted by CuriousNetEntity on Tuesday, September 22, 2020

Yes, this is definitely new. There were some accessibility settings, but they did not stop VoiceOver from being painfully verbose and disruptive. Now to see if I can get my phone to be used as a WebCam for my Mac again. That had stopped working a few months ago, so I found a Zoom on my Mac completely useless and I'm noxious

Submitted by Jackie Larrauri on Saturday, October 10, 2020

Hello,
I am trying to see if there is a way to turn off the alerts, or reroute them to my headphones when hosting a meeting and sharing both screen and sound.
I have tried:
1. Voiceover on headphones and system sound on mac speakers with microphone unmuted. This results in people hearing both my voice and sound, such as youtube videos, but also means they can hear when notifications come in such as an alert letting me know someone has raised their hand.
2. Having voiceover and system sounds on headphones and sharing computer sound on zoom. Again this results in the same issue when outside of the app. If I am in the app, notifications come through my headphones alone.
3. I've tried changing sound output settings on zoom itself with the same results.
I have all screen reader alerts off, but when I'm hosting a meeting and sharing my screen and sound via any of the above methods I still get the notifications. Again, notifications are only heard by others when I am not on the zoom app, such as when I am on chrome or word and sharing my screen. When I am in the app however, I am the only one who hears these notifications which is what I want so that my students don't all hear when someone raises a hand, incoming messages that may or may not be private, or when someone is in the waiting rooml.

Submitted by Karina Velazquez on Sunday, October 11, 2020

Well first of all thank you for giving us this amazing news! but I don't understand when I check or uncheck the option for when a participant joins or leave, it also says something of being host, but I don't know if this alert will only stop when unchecked, if I'm the host or that it will only be read if I'm the host, no matter if it is checked or unchecked.

Have you try it in a meeting?

Submitted by Ekaj on Sunday, October 11, 2020

Thanks for posting. I joined my church's Zoom service this morning, rather late. I had to turn off VoiceOver altogether, but I'll definitely look for that setting you speak of and I will share this with a sister and our parents. I'm going to be participating in a workshop along with a neighbor 4 days a week. Or at least whenever possible.