Any way to manually grant an app microphone access

Forum
macOS & Mac Apps

Hi all,

I've recently upgraded my Mac to MacOS Catalina and have downloaded the 64 bit version of the RS Games client. Everything's working fine apart from the voice chat feature. For some reason, the RS Games app does not bring up the prompt asking for microphone access, therefore MacOS automatically denies it, meaning other players cannot hear me.

There doesn't seem to be a way of manually granting it permission in system preferences, and uninstalling and reinstalling has made no difference. Is there any other way to manually grant the app microphone access? I'm assuming there will be a Terminal command for this, but haven't found much from Googling. I have emailed the RS Games developers about this a few days ago but have had no response yet, so thought I'd ask here as well.

Thanks in advance for any help.

Options

Comments

Submitted by Christopher Duffley on Thursday, April 2, 2020

That's cool! I myself just started using RS earlier this week and am loving it! If you, or anyone for that matter, would like to play me, hit me up at CDuff2001! Anyway, I'll have to check this for you as I haven't used voice chat yet myself. I'll reply to this comment once I see something; wouldn't be shocked if it was System Preferences > Security & Privacy > Privacy followed by Microphone or something like that.

Take care!

Submitted by Christopher Duffley on Thursday, April 2, 2020

In reply to by Christopher Duffley

You're absolutely right about RS not showing up in SP as I just looked there myself. Hmm...I'll have to do some research and let you know here what I see.

Submitted by Callum on Thursday, April 2, 2020

In reply to by Christopher Duffley

Hi,

Thanks for your comment. I already tried in the microphone settings of system preferences, but it appears an app only shows up in there after it has given you the initial prompt of "This app would like to access the microphone". There doesn't seem to be an add button there either.

Do let me know if you find something. :)

Just tried that and it made no difference unfortunately. Still no prompt when opening the app or enabling voice chat, and still nothing in system preferences. Thanks anyway though.