Answering calls quickly enough.

Forum
macOS & Mac Apps

I'm having a really annoying problem. I don't so much think this is really a Voiceover issue as much as it's me not having fast enough reflexes, but I wanted to see if anyone may know an easier way to deal with this.

I have been using my macbook air for a few days now, and have gotten, on occasions, a phone call to my iPhone. I have my mac set up also to make and receive calls using my iPhone over wifi. So, when a call comes in, my mac also pops up with Facetime letting me either reject or accept the call.

What I find is, even though I hear Facetime notification, if I interact, I can't immediately find with Voiceover the accept or decline buttons. What I'm having to do is command+tab until I get over to Facetime, then once Facetime is in the foreground, I then have to do VO+F2 F2 to open the window chooser, find the notification window, VO+Space on that from the window chooser, then VO left and right around the screen to get to the answer button, and finally hit vo+Space.

In the time it takes me to do all that crap, the call has already gone to voicemail.

Using Big Sur 11.2.3, I just am wondering if there is a much quicker and more efficient workflow to quickly get over to that call alert window and hit the answer button.

Let's say I was in the Mail app, and all a sudden I get a call. Or maybe I'm in Safari looking at a website, and all a sudden get a call.

What would you press step by step to quickly jump over and get to that answer button? Or, am I unfortunately doing this already about the easier way there is.

Options

Comments

Submitted by Herbie Allen on Friday, April 9, 2021

After you command tab, do VO right arrow and that should get you to the accept button. One thing I did was change the FaceTime notifications to pop up so that most of the time, the window is right there. Also, keep your notifications cleared. You can now access them by doing VO O and interacting with the Notification Center. You can Command VO space on any notification and clear it that way.

Submitted by Bruce Harrell on Friday, April 9, 2021

Have you tried a 2 finger double tap on your touch pad?

so, I'm a little bit confused on one thing. you said that when I receive an incoming call, simply just VO right arrow once to the except button. before I do this however, do I first need to interact with the notification?

secondly, how do I set FaceTime specifically to a pop up for notifications? I assume that that is under system preferences, but can you elaborate a bit on that, and be a bit more specific on where I go exactly to do that?

Submitted by Angel Blessing on Friday, April 9, 2021

Ok, try doing a vo end meaning the end key on your six pack of keys to get to the button you need, let us know if this worksf or you.

Submitted by Herbie Allen on Friday, April 9, 2021

You should be able to VO right without interacting. You go to Notifications in system Preferences. I have tried the Trackpad method and I had no success.

Submitted by Christopher on Friday, April 9, 2021

In reply to by Angel Blessing

Ron,

The issue isn't that I can't find the answer button quicly enough once in the call alert window. Yeah, once there, VO+end, then a few VO+left arrows will get you to the answer or deny icons. The problem is that I can't get to the in call alert window in the first place quickly enough.

When the notification comes up, it's not acting like normal notifications. It's not as easy as just hitting VO+O to open the notifications area, and if you command+tab to Facetime, then start attempting to navigate, all you get is, "Facetime has no windows." So, then you gotta middle muck your way around with VO+F2 F2, get to the notification alert window, and then, your suggestion finally would work. But getting there to start with. That's where the trouble is coming in.

I like the idea given of maybe making Facetime notifications be actual popups. I've just not totally worked out in system prefs notifications how exactly to make that happen. I need to look at that a bit more closely maybe later this evening. That actually might work.

Submitted by Bruce Harrell on Friday, April 9, 2021

If you're trying to get to another window, why not use vo-tilda or vo-f2 f2?

Submitted by Christopher on Friday, April 9, 2021

In reply to by Herbie Allen

When we talk about setting Facetime notifications to popups, I don't see anything in notifications under Facetime for that. The closest thing I see is instead of none, or bannars, you can set to alerts. I changed it from bannars over to that.

Is that what yall're talking about?

That's not dumb of you asking this. Fair enough question. As I've said though multiple times, that works. It's just that doing all that middle muggerring around takes too much time, and by the time you get over to the correct window within FT, the call by then has gone to voicemail. So, that's why I was trying to see if there was a faster way. Don't worry though about your question. It's all good. Like I said, I don't think it was dumb at all!

Submitted by Herbie Allen on Friday, April 9, 2021

Yes.

Submitted by Christopher on Friday, April 9, 2021

In reply to by Herbie Allen

So now that I've changed that, I guess what's gonna now happen is, when I get a call while in the middle of something else, no command tabbing or interacting necessary. All that'll happen is, as soon as I hear the ring tone go off on the mac, I'll no longer be in Safari, Mail, or wherever. Given we set this now to alerts, it'll pop up in the foreground over what I was doing, and the alert will be the foreground focused item, no longer Safari, Mail, or the like. So now, don't interact. All I need to do is hit VO+Right arrow, and I'll eventually get either to accept or decline. Hit VO+Space on whichever I need, and boom! Presto! Am I following this process at this point correctly?

Submitted by Bruce Harrell on Friday, April 9, 2021

Thanks for the reassurance. I'm trying, and so I have another suggestion.

First, using keyboard commander to set up hot keys or shortcuts or whatever they're called, whenever I want I thereafter use the right option key plus a designated keyboard letter to go directly to various apps, e.g., right option plus l to open Logic Pro X.

Have you tried using keyboard commander in a similar fashion to be able to immediately open facetime with a single keystroke whenever you want? Also, once facetime is open, what is the default key? If it's "accept call", all you would have to do is hit the return key. Hence, a 2 keystroke process once the phone starts ringing?

Bruce, keyboard commander is only for assigning Voiceover functions to as you said the right or left option key depending on how things are set, or you can open a chosen app with one keyboard shortcut.

I think what you and a few others here are failing to understand is, this has nothing at all to do with not being able to get Facetime launched. That is not the issue.

Go study up on the window chooser, and what is meant by apps having various windows within them.

When you are in Facetime, you have the main window which has all of your things like the search box, the table of recent calls both inbound and outbound, etc.

When you place an outbound call, or receive an inbound call, either way, a child window pops up over the top of the main Facetime window.

A good annalogy for this is, let's say you open up Text Edit.

You type your document, then you hit command+S to save. now you get the save as dialog that pops up on the screen in the forground. You're still in Text Edit itself, but you have this second window, the save as dialog, which is over the top of the main document edit area which is now behind the save as dialog.

So the hierarchy would be, the main Text Edit window, then under that is a child window which is the save as dialog.

So, the main window where you type the document itself is a parent window to the save as dialog.

However, let's say you have two apps opened... We'll just call it, Safari, and Mail.

Nothing in Safari is a parent Window of anything in Mail, and same vice versa.

So, when you hit command+tab, you're cycling between all opened apps at their top most level.

Once in the app, this is where you hit either command+accent grov, or command+shift+accent grov to move back and forth between opened windows within the currently focused app, or you can do it the Voiceover way with the VO+F2 F2 method. VO+F2 F2 doesn't move you between apps. That moves you between windows *within!* the current app in the foreground.

OK, now that we have that cleared out of the way, Fewwwww! Let's go back to Facetime.

You have the main window. Then, when you get an active call on the receiving end, what happens is, Facetime opens even if not before hand launched. Now, you have two windows temporarily.

You have the main Facetime window with the table of your recent calls, the search text box, the radio buttons for all calls or missed calls, etc.

Then, as the ring tone is sounding telling you of your incoming call, that pops up as a child window of the main parent window of Facetime.

So, that said, if I'm in something like Mail, or maybe Safari, or somewhere else, maybe Pages, or wherever, doesn't really matter, just some app aside Facetime, and I get an incoming call, what happens is, first off, Facetime does not become the foreground most focused item. So therefore, let's assume I had been browsing the web when the call came in.

I'd therefore still be with Safari in the foreground. So, I'd have to command+tab however many times through all my opened apps, or hit VO+F1 F1 to move through the list of opened apps, either way. Focus myself into Facetime being the active app in the foreground, now thereby making Safari be in the background. Then, once Facetime has gained focused, never mind that while doing all this, I'm running out of time for my call to be answered before going to voicemail, I then have to quickly move between the child windows within Facetime, and find the window containing the incoming call alert notification. Once that's done and brought to focus, then, finally I can navigate to the answer or decline button.

What I'm saying basically here in my initial post is, by the time I do all of that messing around trying to get to the answer button, too much time goes by, and the call by then has been forwarded on to my voicemail.

The suggestions, Bruce, you're giving are great, don't get me wrong, but I don't think you have a totally clear concept on what is happening, and why.

Though this was very lenthy, I hope that now you better understand the predicament.

I think the sollution of setting the notifications to alerts instead of bannars was actually probably what will wind up resolving this to my satisfaction. I've not since changing that gotten an incoming call to test with, but we'll see what happens whenever I next do.

Submitted by PaulMartz on Friday, April 9, 2021

Member of the AppleVis Blog Team

I'm sure I posted about this same issue some time ago, and it's disheartening to see others struggling with it.

iOS handles this elegantly with the 2-finger double tap, a gesture with a varying effect depending on the state of the device. If the phone is ringing, 2-finger double tap answers. If you're in a call, 2-finger double-tap hangs up. If the phone is idle, 2-finger double tap plays media.

Why can't Big Sur let us define a similar context sensitive hot key?

We should not have to find a friend who has no life and beg him to patiently make repeated calls to our phone so we can experiment with a dozen settings and techniques.

Submitted by Christopher on Friday, April 9, 2021

In reply to by PaulMartz

I wonder, and am not by my mac right this moment to test, how possible it is that the two finger magic tap *would!* work, provided that trackpad commander was on. Bruce has suggested this earlier in the thread, but I didn't think about that earlier. I doubt it would work even then, but, just am saying.

Submitted by Herbie Allen on Friday, April 9, 2021

It does not work.

Submitted by Bruce Harrell on Saturday, April 10, 2021

OK, thanks for the explanation. I appreciate that. Still, I'm working through my checklist of possible solutions, pursuing the age old process of elimination. Here's the next item on my checklist.

Have you tried to Set the Sweet Spot control option commmand right brace right brace on the accept button? If sweet spots are useless due to the nature of the window you are dealing with, is item chooser also useless?

Submitted by PaulMartz on Saturday, April 10, 2021

Member of the AppleVis Blog Team

Here's a link to a previous discussion.
https://www.applevis.com/forum/macos-mac-apps/answering-facetime-calls-…

From it, I gathered you must hit VO+O to jump to notifications, then VO+Right to the Accept button.

After trying that cumbersome technique a few times, I decided to simply use my remaining crappy vision. I drive the mouse into the upper right corner, zoom in with Control+Scroll, then manually click the Accept button. This will work until it won't, and hopefully Apple will have a better solution by then.

Submitted by KE7ZUM on Saturday, April 10, 2021

There is a quicker way. vo d, f, then the answer call will be the foreground. I can do that all the time, so I don't see the issue.

Submitted by Brad on Saturday, April 10, 2021

Is there a keyboard answer call shortcut? I believe there is one on skype for windows but i can't remember it now.

Oh! What about that thing where you can ? do thing x on your IPhone and pick up where you left off on your mac, could you do that?

Submitted by Christopher on Saturday, April 10, 2021

In reply to by Brad

There are no shortcuts. What you're thinking of is continuity, but that's still not the point. The point is, this is extremely clunky from an accessibility standpoint, and honestly it would be nice if Apple put more effort into this app. By far, I'm not the first person who's complained to them about this, and started out before complaining by offering constructive feedback. The only reason myself and others have gotten a bit more hostile with them about this is the fact that clearly, they're doing nothing about it.

Continuity isn't going to help with this because you can't possibly expect me to always have my phone right there within reach of my mac. Again though, even if that was a realistic assumtion, which by the way it isn't, again, that's aside the point entirely, no offense.

Sarah, you make it seem like everyone should know that trick. Despite what you may think, not everyone is a perfect, quote unquote mac user who knows everything like you do evidently. And yes, I know you never said that, but you sure as heck implied it. The issue is, since you asked, thank you very much, just that, that not everyone may have known that would put the call window in the foreground. Secondly, not everyone's gonna have Facetime in their dock. And don't tell me, it's there by default so yeah it should be. You're right, there it should be, but if people have wanted to clean up their dock as I have, they may have removed it. I personally didn't, but some may have, at which point, that trick wouldn't work for them. Finally, just for the record, Facetime *is!* in my dock, and I tried your method outlined. It still for me didn't work as you describe. It definitely does bring FT to the foreground, but still FT has no windows.

the only way I found to fix this consistently was to do what early on was suggested by changing the notification type to alerts instead of bannars.

This is a fantastic idea/suggestion. The only issue with this is the fact that again, that window would have to be first focused for the sweet spot to work. The issue isn't gaining focus to the accept button. The issue is getting to the window quickly enough that contains the answer button. Just focusing Facetime alone doesn't seem to be bringing the call alert window to the foreground.

I'm really getting incredibly frustrated trying to better explain this. Obviously I'm stupid and don't know how to best explain things. It's not your fault nor anyone else's, but I don't know how to explain the issue any more clearly than I have already, and I honestly feel like at this point, trying to is gonna be a waist of my time.

I appreciate everyone who chimed in trying to help.

At the end of the day, setting the notifications type helped. I don't think that is a realistic permanent sollution by any means of the ball game, but, it definitely is a work around which seems to be consistent. Until Apple gets off their sofas and fixes this/listens to the feedback specifically regarding this that all of us having the same or similar problems have reported, it'll have to do.

How Ke7ZUM or rather, Sarah, is getting that with VO+D in her dock to work, I have no idea. I don't doubt that it's working that way for her consistently. I don't think that she's being untruthful, let me be totally clear with that. I'm not at all accusing her of that. I'm just simply saying she's lucky, as 99 percent of us apparently don't seem to be having much luck with that method.

I think continuing this conversational thread up here at this point is just gonna be beating a dead horse in the ass. Let's just drop it for now. With all due respect. Again, not anyone's fault, but, we're getting absolutely nowhere with this. A temporary sollution has been found, thank you for that. Let's just for now consider that the answer until Apple gets this better implemented.

If I sound a bit harsh in this message, I apologize, but like I said, I'm frustrated, so cut me a little slack.

Submitted by Christopher on Saturday, April 10, 2021

In reply to by PaulMartz

Aa! I get it now, so in other words, basically, what I'm hearing said from this other post you linked to is, in Big Sur, the in call alert overlay, if you will, isn't actually a part of the Facetime app. It's actually it's own separate process as means manifesting if you will as a push notification. Thereby, just like when getting a text message or something, same principle. It's showing up as a notification, hince why hitting VO+O, which is new in Big Sur to focus your notifications area, then interactin works, as it is the most recent notification. Once inside the notification by interacting with it after jumping to your notifications with VO+O, then you get all the options like accepting or declining. OK, that actually makes total sense. I wish that someone had told me this at the beginning of this thread.

What I wasn't understanding was happening was, I thought that the in call alert screen was not just a popover toast notification. I literally thought it was an actual separate window contained inside the Facetime app which popped up over the top of the main FT window, hince why I was thinking in terms of the VO+F2 F2 method to change between windows within the app.

This now totally explains exactly why that wasn't reliably working. I will give this a try next time I get a call, but hot diggity dawg! You may have just answered my entire question. If so, you're a lifesaver!