Adobe reader dc update for mac

macOS & Mac Apps

Hey everyone

As I posted last week, Adobe has claimed that its latest update to its pdf reader app on the mac brings full accessibility to tagged pdfs. That update came out today.

I have not had much time to look at the app yet, but my first impressions are mixed. It is definitely better then the previous reader app, since that one was totally inaccessible to voice over. You can read text in the new app, although it seems to make voice over a bit sluggish. You can also check boxes, and use, both skip nav and web links I believe.

There are a number of things that I don't understand about the app yet, for example it looks like there is a way of accessing headings, I can navigate through them, but I can't seem to move focus to them. I also can't figure out how to type texts into form fields. There also just seem to be some stability issues; as i mentioned the app is slow. Also it has already crashed on me a few times, and navigation seems to be a bit inconsistent.

I think there could simply be things that I am missing. Adobe says it is working on a user manual for voice over users, perhaps that will clear things up. I would love to hear from other people about your experiences with this app. I don't think its as good as it could be, but it is, perhaps, a start for a truly accessible pdf reader on the mac.



Submitted by Tree on Tuesday, April 7, 2015

I have been fiddling with the app some more, even though I should be working on my paper right now.

I have figured out how to enter text into text fields; all it requires is a VO command space. So it looks like this is a viable option for filling out forms.

Also it looks like hitting left and right arrows with quick nav turned off moves through pages. I think the up and down arrows is suppose to move through headings, I can't seem to get this to work consistently yet.

Submitted by chad on Tuesday, April 7, 2015

hi i just got the adobe dc reader and if i hit left and right arrows it don't move me through pages and up and down just bonks at me same thing using left and right arrows
do i need to set up anything in the menus

um thats interesting. I really don't know, theres a lot about the app that I don't fully understand and trial and error seems the best fix. If you go into the toolbar and hit one of the next or previous page buttons do those work? Just want to trouble shoot and make sure its the arrow keys not the document that you are in.

Moving through pages does seem to be one of the more annoying parts of the app so far. For example I have not found a way to be able to read a document strait through without having to deal with turning pages; I hope there is a way to change that, but I have not found it yet. I have been playing with the settings and preferences a lot, so I can't say for sure what to try, there are several options for how the app reads pages, although they don't seem to change much from my experience. You might try either changing some settings in the accessibility preferences, the reading preferences, or the page view in the view apple menu. Sorry I can't be more help. I'll Update this if I find out anything els.
By the way, I just realized that the save and save as menus seem to be inaccessible.

Submitted by J.P. on Tuesday, April 7, 2015

Hey Chad,
If you can't navigate with arrow keys, you might have quick nav on. Turn quick nav on/off by pressing left and right arrow at same time. See if that allows you to use arrow keys.

Submitted by Chris on Wednesday, April 8, 2015


So, I just downloaded thisand it doesn't work. When I open a pdf document in Adobe Reader, it asks me to prepare the untagged document for reading with assistive software. I press the start button and it says the document is being processed. However, when the document window comes up, I can't find the document area. All VoiceOver reports is that there are a bunch of controls like a toolbar and some other groups that contain buttons.

When I open the same document in Preview, it reads perfectly. Any help here? I don't get this. From what I can tell so far, this application is crap!

Interact with the element that says the extension of the file you opened. I know it takes a little poking around.

Submitted by Piotr Machacz on Wednesday, April 8, 2015

I created a forum thread about this app a few minutes before you did, but since discussion seems to be focused here, I'll just paste what I wrote there. This will either help somewhat or make life even more confusing than it already is.

My findings, after downloading a couple of accessible pdf's is that it's finicky to get going, but once you do it works quite well. In the preferences you can configure how the text gets processed by screen readers if it's a big document, amongst other accessibility options. You can also configure the built-in read aloud feature, something you should probably do if you want to read long documents. This is because at the moment, the VoiceOver say all doesn't work and will only read what's focused. Once you open a file, you will need to interact with the document pane which will be read as the path to the file. If you don't see it, press the window's zoom button which should fix it. Once you interact, it feels very much like reading a webpage, navigation keys included, so that's good. Tables don't seem to be recognised properly and just read as "empty table" though this could be the files I tried. I also tried filling in a form. The VoiceOver cursor doesn't seem to follow the keyboard focus at all. If you see a form field in the text, you ill have to click it with the mouse, or tab into it. Tabbing does at least work and I was able to interact with text fields, buttons and check boxes but I had no idea how to make a choice out of the combo box.
Other than that, There's a few unlabelled buttons, I couldn't really find a table of contents, but it's definitely a step in the right direction, probably better than preview but it still needs some work IMO.

Submitted by Tree on Wednesday, April 8, 2015

I noticed the same thing about tables that you mentioned, but I was not sure weather or not they held actual content, or if they were just excess elements. If you have looked at a file that you know has a table in it I guess that means tables are not accessible right now, which is disappointing.

I'm glad to hear that navigation keys work, I have not tried the app on Yosemite yet, so I was not sure.

What kind of performance have you experienced? I played around with the options for reading and cashing different amounts of the file, currently visible pages etc. but it didn't seem to make much of a difference; I would appreciate hearing your findings. As I mentioned the app lags in my experience, but my mac is a bit slow in general. I also experienced slow performance on my work mac, but maybe newer machines would be snappier.

To play with a file that has a working table of contents try this adobe user manual for screen readers.…
The beginning of the file has a list of internal links that will take you to different parts of the file.

At one point hitting the up and down arrow keys, with quick nav turned off, seemed to move through headings for me, but for some reason I have had difficulty getting this to repeat.

It seems like the biggest issues right now are;

1. inaccessible tables,

2. difficulty accessing headings,

3. the inability to read more then one page of the file at a time with commands such as, read all.

4. general lagged performance, although this issue might be specific to my machine, or perhaps configuring the settings in a way that I have not figured out yet will help.

A note on the read aloud feature. I don't believe that it should be seen as a viable option for reading the document, because the feature has existed in the previous versions of adobe reader as a poor alternative to voice over accessibility. I have written in the past on this site, about how to use this feature to read documents and even fill out forms,…

but I believe that this feature has worn out its usefulness and we should look to moving forward with this new update to the app.

This app makes filling out forms accessible, gives access to alt texts in images, has working links and a working table of contents if tagged properly, and can probably offer a pretty good reading experience if Adobe makes some tweaks. If combined with those tweaks tables and headings are made accessible we will finally have a pretty good option for receiving full access to pdfs on the mac

Submitted by Apple-pie on Friday, May 29, 2015

Hello, I've just tried out Adobe Reader for Mac. My impression is that VoiceOver does not read the hole page when pressing the read all command. I read one page but when I press the next page command and continue reading then there starts a new text that doesn't continue with the text on the page before. I also tried it with the Adobe Manual and tried out different pages. It's always the same result. Moving through headings by pressing arrow keys doesn't work either. For me this app seems not very accessible but better than it was. Is there an address where one can give some feedback?

Submitted by Raul on Friday, May 29, 2015

I always get the alert from the subject when reading a document. I tried both fillable and text only documents.

Submitted by Thomas Byskov … on Thursday, August 13, 2015

How do we give them some feedback? I've had a couple of issues with scrolling and changing pages in PDFs, and I would be happy if I knew how to contact their accessibility folks. I actually noticed something strange earlier when I played around with the app: In a document I opened it removed some spaces between words. I know that because I've read it in Preview and in Windows, where the spaces aren't missing. Is this a bug, or me who need to change a setting somewhere? Best regards Thomas

Submitted by Ahmed on Monday, November 25, 2019

In reply to by Tree

That’s correct Tree to move through the document you use control-option and the arrow keys VO-A does not work right now at least

Submitted by KE7ZUM on Monday, November 25, 2019

When I tried that last year, it would crash like an airplane out of control.. I di dreport that to them via their support many times but I have since uninstalled it and use prefview or pef escape to fill out my stuff when I need to.