Accessing notifications in mavericks

Forum
macOS and Mac Apps
Hi, I've been using mavericks for about a week now, and I love it. There's only one thing that's bugging me quite a lot at the minute. In OS10 Mountain Lion, notifications like "the disc wasn't ejected properly", or "none of your preferred wireless networks are available" appeared as separate finder windows. However, in OS10 mavericks, they now show in the upper right hand corner of the display, and I haven't found a way with VO to get at them. Another example happens when you first install mavericks. You get a notification saying welcome to mavericks. The only way I've found to get rid of them is when a sited person dismisses them for me, as I don't know they're there and they obstruct the screen. Hope you guys can help me. Thanks, Kieran.

Options

Comments

Submitted by robin24 on Friday, November 1, 2013

Hi, that's kind of weird! When I get such notifications in 10.9, the VO focus is moved to that notification, and I have to click a button to dismiss it. What happens when you press VO+F2 twice while the notification is being shown? This brings up a list of open windows, and perhaps the notification window is listed there. Also, you may try to press VO+m twice to get to the status menu, then press VO+right arrow until you get to 'Notification Center' and then VO+space to activate it. This brings up a list of notifications, and you can possibly clear it there as well. Hth! Robin

Hi, It focuses it when say I'm using it and my battery reaches 5%, but not when ejecting disks. Now, in ML, it did show as a separate window, but now if you didn't know it was there, and you went away from it, you wouldn't know it was still there and I can't seem to find a way of getting back to it.

Hi, I just reproduced this issue kind of accidentally. I had one of those notifications pop up (I believe they're called inline notifications), but at the same time pressed Command+Tab to get to another window. I tried getting back to the notification window using the methods I suggested in my previous post, and none of them worked. However, when I went to the Notification Center and pressed escape twice, VO refocused on the notification. I've now tested this a couple times, and it appears to be a reliable workaround. However it's by no means pretty, and yes, if you receive a notification while away, there seems to be no way of knowing that a notification is showing when using VO. Hope the workaround helps though! Robin

Submitted by Piotr Machacz on Friday, December 20, 2013

Just accidentally managed to stumble up on this. It turns out that while the notifications no longer show up as "system dialogs", they do however now appear in the application chooser under "notification centre". So, what you do is press VO-F1 twice, find the notification centre option, and after you open it you'll see any alerts.

Submitted by KE7ZUM on Saturday, December 21, 2013

Try the usual vo f2 f2. This will show the system dialogues that are there. Then you can do what you want with them.