Smart Invert Colors feature in 10.13.4

Low Vision Accessibility on Apple Products

with the update to macOS 10.13.4 it seems to appear a feature for "Smart Invert Colors".
This feature seems to appear mainly in Safari. When Invert colors is activated, all colors except the image files on web pages are inverted. The feature is nice, but my problem is that I sometimes want to invert the images and I can't find a setting like in iOS to switch between standard invert color and smart invert color.

Does anyone know the solution for my problem?



Submitted by Mohammed Alwahhabi on Monday, April 9, 2018

this problem is not only in images. but also in videos.
to reproduce the issue do this:
go to one of these websites
and invert your Mac colors while browsing these websites.
you will find that videos and photos are not inverted.
the problem is that there is no option in the Mac to stop that smart inverting.
the only solution is to try other browser.
I tried Firefox and it is ok. videos and photos are not inverted.
I didn't try chrome yet.
I contacted apple accessibility support phone and reported the issue.
and it is really annoying me.

Submitted by Bonzai on Tuesday, May 1, 2018

I was using macOS 10.13.2 until yesterday when I updated to 10.13.4. The option to invert colors on embedded videos and images in Safari is now gone.

Pressing the shortcut to invert colors momentarily inverts the entire screen, but then videos and some images return to normal. That might be nice, in theory. But the practical problem is that now I am no longer able to invert colors when I need to invert them. A video with a white screen and dark text will now remain that way. Watching instructional videos with a text I need to read would be difficult, slow and literally painful.

With damaged retinas, too much light causes blurring and haziness and triggers headaches.

If viewing videos and images in Safari and having the option to invert colors is important to you, I would hold off on installing the update and send your feedback to Apple.

Another option is to use Firefox (or another browser) instead of Safari. I preferred Safari, but now I have no choice other than to switch browsers.

If this smart invert behavior is going to expand into more apps than Safari, this will become a huge impediment to using the Mac.

There are two ways this might be addressed:

1. Restore the "Smart invert" checkbox option on the Accessibility / Display system preference pane
2. Add a "Invert colors (classic)" keyboard shortcut

There may still be 3rd party apps that do a simple inevert. Prior to when Apple included the feature, I relied in an app called Black Light.

Submitted by Bonzai on Wednesday, May 2, 2018

I am realizing now that the smart invert problem is happening not only in the Safari web browser but the Apple Mail application as well.

Because I often encounter messages in Mail that have text in the embedded images, if I cannot read those bright images by inverting colors, and there is no alternate text, that means I cannot read the message content.

I just checked the iTunes Store, and it too is preventing me from inverting bright images.

It may be that any app using WebKit, which is the framework available to developers to embed web browser functionality, is using this new smart invert behavior.

These are now two applications I can no longer use. The iTunes Store is not critical but certainly is hindered when I cannot read text in bright images.

I hope everyone else who feels similarly will send Apple feedback at

Submitted by Cab on Saturday, May 19, 2018

Same here. Noticed it shortly after upgrading. I've reported it to the accessibility team by emailing accessibility at apple dot com. I suggest others do the same so they see the importance of this issue.

Submitted by Bo on Saturday, May 19, 2018

I'm finding that I have this issue on my work MacBook Pro, which s still running 10.12, but the latest version of Safari. Perhaps it is Webkit, as suggested above.

And yes, it's interfering with my ability to do my job. I get a lot of screenshots to review with a lot of technical data embedded, and it's near impossible for me to work with it.

Apple needs to give us more control over this.

Submitted by Mohammed Alwahhabi on Saturday, May 19, 2018

when I contact apple they say, why you want to see videos inverted?
They also did the same in my Apple TV 4th
in tvOS 3 there was an option to invert color of everything in the system
but now you cannot do that anymore.
my Mac now is useless.
I cannot read charts and see video tutorials anymore.
we need someone to send this thread to someone who can fix this thing in apple.

Submitted by PaulMartz on Monday, May 28, 2018

Member of the AppleVis Blog Team

I just noticed if I print a web page, the images come out inverted. Smart invert doesn't seem to be as smart as we would like.

Submitted by Mohammed Alwahhabi on Thursday, June 7, 2018

I think the solution is to write a CSS stylesheet and use it in Safari. The stylesheet should force images and videos to be inverted.
I am not an expert in this thing but I hope someone help us to do it.

Submitted by Cab on Thursday, June 7, 2018

I’ve got this email from Apple with a workaround:
Take a screen shot. (Cmd+Shift+Control+3 or Cmd+Shift+Control+4 copy to the clipboard w/o dropping a file on the Desktop).
Launch Preview and open a new document (Cmd+N). The default is to load the contents from the clipboard.
Use Invert (Ctrl+Opt+Cmd+8) to view the invert chart there.

Submitted by Gary C on Saturday, June 9, 2018

I am a visually impaired Mac user, and I have seen the same issue with Mac OS Invert Colors. As of 10.13.4, I noticed "Invert Colors" is now "smart Invert Colors" as it is known in iOS. But there are no new controls to disable this "smart" image inversion behavior, as there are in iOS.

I reported this to the Apple Accessibility team on 6/4. I called the Apple Care 800 number (800) 692-7753‬. I was transferred to an Accessibility specialist named Taylor. He was able to reproduce the bug. He said he would submit a change request with the development team.

I received a follow up email from someone else, with the workaround of taking a screen capture, and viewing it in Preview. I replied to that email, saying that workaround won't work for video I emphasized that visually impaired people need a true "pixel by pixel" invert of the screen, that will work on still images and videos. They replied that they will forward my request to the developers.

If you watched Apple's WWDC event this week, you may have seen that Apple is going to introduce a "Dark Mode" to MacOS, where each app typically has white fonts on a black background. Apple previewed this feature throughout WWDC. Every WWDC demo used Dark Mode. The software is already available to Apple Developers in an early access beta trial. My guess is that this "Smart Invert Colors" bug was introduced by new Dark Mode software.

I am new to this user group, but I would like to request others to report this to Apple.

Apple Accessibility specialist Taylor taught me that anyone can call Apple Care support with accessibility issues. You do not need Apple Care to get help with accessibility issues.

Here is what I requested:
Allow me to specify some Accessibility options so that when I use the Invert Colors shortcut (CTRL + OPT + CMD + 8), I get a "pixel by pixel" invert colors on my screen.

Bonus points if I can get pixel by pixel Invert colors on my Apple TV, either natively with an Apple TV accessibility shortcut, or using AirPlay.

Apologies for the long post.


Submitted by hawbaker on Monday, June 11, 2018

I just developed a Safari extension that I think will please many users here. I know I am :D. Please take a look at this page, See Better Smart Invert ( The extension allows you to switch between smart and classic invert, also can do so separately for images and videos. My email contact is on that page at bottom. You'll have to click 'Trust' after installing it. It makes no network calls and does exactly one type of function, modifies the current page's stylesheets. Be sure to refresh any pages you already have open after installing.

Submitted by Daniel on Monday, October 15, 2018

Does anyone know if Apple has fixed this issue in macOS 10.14 Mojave by now? For certain reasons I am still on 10.13.4, but I would be very interested to know if it has improved.

Submitted by PaulMartz on Sunday, November 25, 2018

Member of the AppleVis Blog Team

I'm on Mojave, and I can tell you there has been no change to this issue.

Making matters worse, I tried to download the See Better Invert Colors extension, but mojave wouldn't let me install it, saying "unsafe extensions" are no longer supported.

Someone mentioned dark mode above. In my opinion, Safari breaks dark mode. With all other settings default but dark mode enabled, Safari ignores dark mode and renders black on white for most web pages.

So, we currently don't have a fix, and the workaround isn't viable (as noted above).

Submitted by hawbaker on Sunday, November 25, 2018

Thank you Paul for trying See Better Invert Colors safari extension ( I am the developer ). Apple changed how extensions works in Mojave and also in Safari 12+ in previous macOS versions too.

This removed the ability to use the old Safari Extension, replaced with now called "Safari App Extension". I need to rewrite my extension to this new format, but I need find the time first ;) When I do, I will post it here.

Side note:I contacted Apple Accessibility about this awhile ago. They said they are aware of this and has fix in works, but I have yet seen this fix. That's why I wrote this extension as a temporary fix until they do.

Submitted by David Goodwin👨‍🦯 on Tuesday, October 8, 2019

Member of the AppleVis Editorial Team

It appears that Apple may have addressed this issue in Catalina.

In System Preferences > accessibility > display, there are now checkboxes for both ‘Invert Colours’ and ‘Classic Invert’. The help text for this says:

Description, Invert colours on your display — for example, show white text on a black background — except in photos and images. To also invert colours in photos and images, choose Classic invert.

I am not a low vision user, so would love to hear whether this does in fact resolve the issue discussed in this thread.