Latest update broke Audible.

I'm running IOS 13.2 on an Iphone X, and the latest update of the Audible app has made it unusable. When I try and open Audible, it just goes to tries to open, and then closes on its own.

Maybe don't install this update, and I'd be grateful if anyone has an idea to fix?



Not sure but

It seems to work fine for me. Maybe it's a device related issue.

I think it was the update

I think it was the update, but don't know for sure. I deleted the app, and reinstalled. It works now, but I'm going to have to download all the books I had on my phone.

Ah well, I'll consider it an opportunity to cull my downloaded books.



Glad you got it working.

Same here

Having the same issue on iPhone 8+.

Open In Airplane Mode

This happened to me after a previous update. Audible said back then to open the app for the first time after updating in Areplane mode. I tried it this time when the app crashed immediately after launching and it opened successfully. You can then turn airplane mode back off again and the app should still open. Least ways it does for me.


This happened to me, and I just did a reboot of my phone. Seems to work fine now for me.

Offloading then reinstalling

If you go into the iPhone storage section in your general settings where the audible app is located you can offload the app as well as completely uninstalling it. If you offload the Audible app you will save all books on your device as well as the finish tags. This did restore the use of the audible app on my phone. Hope this helps everybody.

Same problem here.

I've just tried the suggestion of airplane mode, and that didn't work here. Trying a reboot of my phone, then will move on to uninstalling and reinstalling the app if I need to.


Lucky me that I am not dealing with that bug. Have current audible app and is doing well.

Spoke with the Audible team

I tried every suggestion mentioned, and nothing worked for me. I got in touch with the Audible team via Twitter, and they said they are aware of the issue and that a fix will hopefully be out soon.

I've noticed similar

I've noticed similar behaviour in a couple of apps namely Newsify and DnDBeyond. Seems to try and load but can't. I'd say the commonality is that they are all checking for online resources as they boot up. I think it's a 13.2 bug.

New update

The new update released a few hours ago seam to have fixed it for me.