Just installed IOS 9, Apple keyboard no longer types in an input/edit mode, please help

I saw another discussion thread similar to this but my problem is that the keyboard no longer types at all. So, I installed IOS 9 this morning. Since then, getting into an edit mode in everything (email, messaging, other chat, etc), I cannot type at all. I can bring up the on-screen keyboard and go one letter at a time but keyboard typing is no longer working. I can control the iPhone with the keyboard, however, but no more typing. Any ideas?

Forum: 

#1 I have a similar problem on

I have a similar problem on my iPad Air 2 with a Belkin keyboard. Seems to be buggy.

#2 I think I have a solution

I think that the split keyboard is the cause of not being able to type. Go to settings > general > keyboard and look for the split keyboard option. Turn the slit keyboard option off.

#3 There is no split keyboard option.

This is an iPhone 5S. Maybe, the split keyboard option is for iPads? Thank you for the idea anyway.

#4 Question

Hello,

Question. When you go to an edit field, double tap it to try to enter something then listen to VO. Does it say character mode? Or does it say something else? It may be a rotor setting issue.

Let me know what you get.

#5 What it says

Insertion point at end, Quicknav off.

Thank you.

#6 had this happen to me, here's a possible fix

I had this very thing happen to me this morning, and was able to fix it by doing the following.
1. go to the first page of your home screen, I always do this just as a starting off point, you can do this from anywhere but I like to make sure I'm on the first page.
2. Press the power button 6 times in rapid succession, click click click, click click click. Then your phone may go silent for a second, but don't worry. What we just did was reset the phone, I like to call this a soft reset. That might not be the proper term for it, but that's what I call it.
3. Now in a few seconds, VoiceOver will start talking again. Now try to type in an edit box and it *should* work. If that still doesn't work, you can try turning the phone off and back on again, or do a hard reset by holding the home, and power buttons in together for about 15 seconds or so. This is sort of like rebooting your pc, if that makes sense. I hope these suggestions help.

#7 Thank you

Hard reset worked. I thought about turning the phone off and back on before but that did not work. The hard reset did. Thank you so much.

#8 I found a solution myself.

i found if we are turning on the phone or in another words, if we are unlocking the phone first, before turning on the keyboard, it's not working. Rather if we turn on the keyboard first, and pressing the shift key for few times until it's asking for the password to unlock, it's working ok at my end. lol. Each their own. lol.

Raaj.

#9 Having this issue as well.

Having this issue as well, mostly in password fields, go to type 1 letter or 2, and end up by the time I've entered my password, 40 charactors are there! this is on 9.3.2 on an Iphone 5C