wierd issue with siri

Forum
iOS & iPadOS

Hello all. Today, I have noticed a weird issue with siri. When using a wifi network, siri will come up when I press the home button, but after I speak my request, nothing happens. If I switch over to my data, siri works as it should. Here are the steps I've tried to fix this problem, and I still have the same result. One, I tried resetting the network settings. Two, I tried turning siri off and back on. Three, I tried resetting the router. I do have unlimited data, but I would prefer to stay on wifi if possible. I'm using an I-phone 5s, with the latest IOS installed. Any other tips on how I can fix this issue are welcome.

Options

Comments

Submitted by Kevan on Tuesday, August 4, 2015

Is it perhaps that the Internet connection on the wi-fi network isn't too great?
Maybe that's why it isn't working. Either that or something is blocking Siri from working. I never have had too many problems with Siri.

Submitted by david s on Tuesday, August 4, 2015

Hello,

It’s an internet connection issue. I have encountered this a few times.

When Siri does not respond, open Safari and see if the website loads. IF a website does not load, you have a bad connection. Keep in mind that the website that comes up may be cached so be sure to click on a link on the page that appears.

HTH and good luck.

Submitted by treky fan on Thursday, January 4, 2018

I know its not my internet, because the same thing happened when I was using my data. And another thing, if I swipe right in something, for example, a weather forcast, I will be kicked back to my home screen.