VoiceOver not reading the first character when the rotor is set to lines both on iOS and Mac

iOS & iPadOS

Hello all,

whenever I set the VoiceOver rotor to read by line, for example, in long paragraphs on webpages or emails, VoiceOver omits the first character at the beginning of any given line except for the first line of a paragraph. It happens only if reading by line in forward direction, as previous lines are correctly read in full, with some exceptions detailed below.

I am not sure if it affects only web content, but on iOS, it also happens in iBooks. By the way, Facebook Messenger does not support the read by line at all, as it reads the whole paragraph instead, or, under some circumstances, does not even allow to set the rotor to lines.

I tried the Alex, Samantha, Siri and the Czech language voices, and all of them exhibit this problem. Neither turning VoiceOver off and on again, nor restarting the device solves the problem.

I have an iPhone SE with iOS 10.0, but the problem already occurred when I had iOS 9. I've noticed the problem exists on macOS Sierra 10.12.0 (and probably in older versions) as well, but its behaviour differs a bit there. On iOS, if you flick up and then back down, the first character is read correctly. But this trick doesn't work on macOS, where, for a change, going back and forward triggers this bug in text fields, which otherwise aren't affected by this bug. By the way, on iOS, the read by line doesn't work in text fields at all, as it causes the VoiceOver cursor to jump out of the text field to the next item, which seems to be another bug.

Before I report these bugs to accessibility@apple.com, I would like to check if somebody else is experiencing it as well, and if you know of any workaround. I would also like to ask you to report it too.

Thanks in advance.




Submitted by Zack on Monday, October 10, 2016

Yeah, this one seems to happen to me too. Just tried it on an email. WOnder if it's got something to do with HTML? At any rate, definitely worth a report.

Submitted by OldBear on Monday, October 10, 2016

I don't use the read by line very often, but it does seem to be happening on my iPhone 6 IOS 10.02. If I flick up and back down it reads the first letter correctly, though.
I've been so distracted by the overactive verbocity on HTML to notice other bugs, but I'll look into reporting it. Thanks for pointing it out.

Submitted by Adam Samec on Wednesday, October 12, 2016

Thanks for your reports and findings. I found the bug to be present on Mac as well, and have edited the post to reflect my new observations about where and how the bug behaves.. I also noticed the read by lines doesn't work in text fields on iOS at all.

Submitted by OldBear on Wednesday, October 12, 2016

Apple wrote back and ask for instructions on reproducing the issue. I explained it in reference to an iBook with several paragraphs, then said it also happened on Safari web pages with paragraphs etc. Hope they can reproduce the issue on one of their machines.

Submitted by OldBear on Thursday, October 13, 2016

Apple wrote back and said they were able to reproduce the issue and passed it on etc.

Submitted by Adam Samec on Friday, October 14, 2016

Today, in less than 24 hours after my report, Apple wrote back to me as well that they were investigating the issue and so couldn't tel when it will be fixed.