voice over problem

Forum
iOS & iPadOS
hi. I have a big problem with vo. my language of vo is set to Romanian as it is my region but when I am on safary navigating on a page vo uses the English voice to read even if there is content in Romanian language or in English. this is really annoing because I can't understand what it says I have to navigate letter by letter. if some one know the solution I would appreciate very much. thanks

Options

Comments

Submitted by sockhopsinger on Wednesday, July 17, 2013

Sounds like you need to make sure that both the keyboard and Voiceover are both set to Romanian. Go into settings, keyboard, and make sure the keyboard is correctly set. Then make sure your Voiceover roter language is also set correctly. Other than that, I don't know what to tell you other than to try restarting Voiceover and/or your phone. Good luck.

Submitted by Mark SARCH on Wednesday, July 17, 2013

In reply to by sockhopsinger

Hi I have a couple questions What's the set up language by default to your device? Do you have selected voiceOver voices under language rotor? How many voices under VoiceOver language rotor have selected?

Submitted by mastodont on Thursday, July 18, 2013

In reply to by Mark SARCH

my default language is set to Romanian as it is my region and I have selected in the rotor Romanian, English and Australian English. whenever I am on a page it speaks the American English voice.

Submitted by Cliff on Thursday, July 18, 2013

In reply to by mastodont

Hi! I see this all the time, especially since I mainly use the norwegian voice. The problem seems to be the website it self. The developer of the website can label the site with the correct language, which then VoiceOver picks up, and changes the language of the speach to fit the websites language. But often developers don't bother to label it right. On applevis the language automatically switches to US english, which in that case is great. But many norwegian websites also causes VO to change to US english, which is very annoying. So what you need to do to force VO to speak romanian, is to make sure romanian is checked in the VO settings under language rotor. Then, when you are on a website that makes VO change incorrectly to english speach, you use the rotor to get to "language", and then choose romanian there. And be sure to choose romanian, not standard language, because the setting for standard language will let VO choose language depending on the content you are reading. Hope this helps! :)

unfortunately it doesn't work. I even removed the English language from the rotor but it stil reads using US English voice. this is really annoing.

'That's wierd... Works for me... I even tried checking what I think might be romanian in the language rotor on my phone, and switched to romanian in the VO rotor, and every website I opened was read in romanian voice... Or romana, I think it was called... Are you completelly sure that you go to language in the VO rotor by turning two fingers around on the ,screen, and then flicking up or down until VO says romanian? Sorry for asking stupid questions, but just have to be completly sure that we're talking about the same thing here... If that don't work, I would try the folloowing in this order, if you haven't already tried it: 1 - Turn VoiceOver off and back on. 2 - Restart the phone 3 - Do a soft reset of the phone, by holding the sleep-key and the home-key down together for 10-12 seconds until the phone turns off and turns on again. Be aware that this usually resets VO settings as well, so you might wanna get sighted assistanse while doing this, to get VO turned back on again afterwards. Or you could connect to iTunes and turn VO back on there... 4 - Do a complete reset off the phone, to it's factory settings. But be sure to make a backup first, either in iTunes or through iCloud, so you can get all your stuff back afterwards the way it was before restoring to factory settings. The last one at first might look a bit drastic to fix a seemingly small bug, but it might just work if nothing else does... If nothing of this works, I'm afraid I'm out of ideas, but hopefully someone else can jump in and give you some more help here... Hope this helps in some degree... :) Good luck! .

I did a soft reset using the home and sleep button together and now it seems to work. thanks for your help.