VO recognising different controls as one control. Any workaround?

Forum
iOS & iPadOS

Hello all,

In certain third-party apps, Voiceover recognises different consecutive controls as one control. For instance, while flicking from left to right wherein there are, say, control 1, control 2, control 3 and control 4 to click, Voiceover in just one flick announces all these control together. Double tapping activates the first control, so there seems no way to click other controls. The same app, if used on android device, they are reported in separate flicks by Talkback.

So wondering if any workaround possible for this reoccuring issue? I tried item chooser, but the result is still the same.

Thanks.

Options

Comments

Submitted by Justin Philips on Sunday, December 8, 2019

If it is a free app, we could give it a try!

Submitted by Yvonnezed on Sunday, December 8, 2019

This is a tricky one. Voiceover is seeing it as a single control, not multiple controls, so there isn't an easy way to deal with it. Things that have sometimes worked for me. Slide your finger across the controls slowly and try to double tap and hold on the one you want. If this doesn't work, you can try finding the control you want by sliding, turn off voiceover altogether, tap it and turn voiceover back on. Really, though, writing a polite note to the developer explaining the situation is probably your best bet.

Sadly, I've often found cross platform apps are the ones most likely to have accessibility problems, due to how they're written.