VO not speaking alerts on locked screen

Forum
iOS & iPadOS

I just updated from an iPhone 6 to and iPhone XR (and am really loving the upgrade!).

Anyway, on my iPhone 6 VO always spoke alerts that came to the locked screen.

Now on my iPhone XR when I get an alert I hear an alert sound but VoiceOver is not speaking the text of the alert.

I do have "always speak alerts" checked in the Settings / General / VoiceOver dialog. Is there some other setting(s) I should be using to have these alerts automatically spoken on the locked screen?

I am using the latest iOS 112.1.2.

Thanks.

--Pete

Options

Comments

Submitted by NS studios on Tuesday, January 1, 2019

Hi,

Do you maybe use a case that covers the whole front of the phone?
I had this problem when I upgrated from 5S to 7, and I found out that newer models (starting from 6S I believe) have ambient light sensor, and certain cases (e.g., the one I have, i.e., the wallet-like kind) cover that sensor making it think it's inside a pocket, which makes it neither turn on the display nor let voiceover read the notifications in order to save battery.
I wish there was a way to disable this behavior, but I haven't found a way.
Hope this helps.

Submitted by Eileen😷 on Tuesday, January 1, 2019

Go to Settings > Notifications and make sure that “Show Previews” is set to either “When Unlocked” or “Always”.

Submitted by peter on Tuesday, January 1, 2019

Yes, I do use a case, but not one that covers the front of the phone as you describe.

Also, with my iPhone 6, when an alert came to the locked screen VoiceOver would speak the message even it the phone was in my pocket. That was quite handy.

Maybe the difference is that with these newer phones VoiceOver won't speak if inside a pocket because of somem light sensor. I think I have heard VoiceOver speak the incoming alerts on my iPhone XR at times when I was able to pull the phone out of my pocket quickly enough. But I don't think it is speaking alerts if I don't take the phone out of my pocket.

Hmmm...Wish there was a solution. I don't want to always have to take the phone out of my pocket to hear an alert spoken.

Thanks.

--Pete

Submitted by peter on Tuesday, January 1, 2019

Yes,I do have "Show Previews" set to "Always". As I indicated in my previous post, I wonder if this is just something with the newer phones having some sort of light sensor. I think what I've been observing is that VO will not speak the alert if I keep the phone in my pocket but will speak the alert if I manage to wrestle the phone out of my pocket quickly enough. I liked the way it used to work with my iPhone 6 - i.e., VoiceOver would speak the alert even if I didn't take the phone out of my pocket. Would be nice if "Always speak previews" really meant "Always"!

Thanks.

--Pete