Virtual card, yet again deleted in Apple pay

Forum
iOS & iPadOS

Hello all. i posted awhile back, my BOFA visa card was deleted from apple pay. i don't know when this started happening. i added it back, it got deleted. Three times I did, until i removed the card in iTunes, then added it into the wallet, then back into iTunes. So why the hell has it been deleted yet again? If I go to BOFA they'll blame Apple, chances are Apple has no idea what's going on. I googled this, I guess apple removed cards if you sign out of iCloud, but I didn't do that. Ugh, I just don't know. So if anyone else has any ideas, please let me know. Thanks.

Options

Comments

Submitted by Anthony on Saturday, December 10, 2016

Hello there yes if you log out of iCloud it will delete the card automatically

Submitted by Siobhan on Saturday, December 10, 2016

If you'd paid attention, I did, not, log out of iCloud nor, have I turned off passcode which would be either case for acceptable deletion of said card. Seriously, i wonder why I bother? I swear I get inane answers to questions I answer in my post. Thanks for the help though.

Submitted by Anthony on Sunday, December 11, 2016

I don't know if you were done this I don't know you might've said this in your post but have you tried backing the phone up to a computer and resetting it up and are just re-download your stuff and you set up as new or backing up to iCloud And sorry if I missed the part where you said that you did not log in iCloud I read log out of iCloud

Submitted by KE7ZUM on Sunday, December 11, 2016

I have not had this issue. As suggested I would do a full blone restore as I think your phoen might be corrupted some how.

Good luck.

Submitted by DJ on Sunday, December 11, 2016

Hi Siobhan

Unfortunately, you're not alone concerning this problem. Other than signing out of iCloud which you haven't done, turning off Touch ID and Passcode may be the cause. If not, I would advise contacting BOFA despite any reservations as the bank is responsible for validating your card. Alternatively, reboot your iPhone and add the card again. I realise this is an inconvenience, but until there is a definitive solution I don't know what else to suggest.

Submitted by david s on Sunday, December 11, 2016

Hello,

Did you log out of icloud? Just kidding. I know you said you didn’t.

Have you tried a different card? If it does it again using a different card, then it’s not a card issue.

Something you can also try before going the setting up your phone as new route, try reset all settings. I’ve been playing around with reset all settings and it seems to work well. Granted, I always have to do it twice before all my settings are wiped out.

HTH and good luck.

Submitted by Siobhan on Sunday, December 11, 2016

Hi. Lol no I didn't and I didn't turn off passcode. I don't have another card to use, the other one is bank of america to, so i'm skeptical. Right now, knock on wood, ow! it seems to be ok. Then again I haven't exactly timed how long it takes to do this. ;) I'm trying not to restore my phone, as backing it up is being weird, it always is but that's another post.