Urgent: Is anyone else seeing this with Bard Mobile?

iOS & iPadOS

This is driving me insane!

Is anyone else, regardless the model you're using of iOS device, although just for reference, I'm using an iPhone 11 Pro Max, iOS 13.4.1, seeing the issue where though you're signed into your Bard account in the app, if you go to the get books tab, then choose browse Bard website, it then prompts you to log in with your e-mail/password every God forsaken time you get to that screen? It used to be, as long as I was logged into the app, which by the way, I am, if I went under get books to browse Bard, it never asked me to sign in. It just logged me in automatically since I already was signed into the app.

This only seemed to start happening for me last night. I've rebooted my phone, no good. I've uninstalled and reinstalled the app, no good. I've reset all app settings under the settings area of the app, no good. I've made sure keychain was enabled, although in the past that didn't matter either way. It was however. I've checked for an app update, nothing. I've closed the app from the app switcher, nothing. I tried on not just my iPhone 11Pro max, but also on my iPhone 10S, and on my iPad 5th gen mini, and all have the same issue. I wrote support, and they told me that shouldn't happen, and they can't help me, as they can't reproduce. They won't even push to engineers, as why should they, in their words not mine, if they can't reproduce it in the first place. I don't wanna go back to using my DTB player, but if I must, I will.



Submitted by BlindWiz on Tuesday, May 12, 2020

Hi, I've noticed today that this is happening to me as well. I can't even log into my account. I think nls bard is having bigger issues.

Submitted by Rixon Smith on Tuesday, May 12, 2020

The library of Congress is aware of this issue. Don Olsen who is in charge of this program and the Bard application put a message up unbarred saying that they are trying to fix it as soon as possible. Hope this helps you

Submitted by Holger Fiallo on Tuesday, May 12, 2020

I just did so and no problems. Using 11 pro max and current iOS.

Submitted by Chris Gilland on Tuesday, May 12, 2020

Rixon, when I log into my Bard account from my PC or mac, where do I then go to find that message? When I log in, I'm definitely not seeing it, unless it was just put up today.

Submitted by Rixon Smith on Tuesday, May 12, 2020

The message I was referring to has always been in the Bard application itself. I do not remember if it is right when I launch the app itself or right after I go into the bard main page itself in the application. Hope that helps you

Submitted by Pa. Joe on Tuesday, May 12, 2020

I have the same problem.

Submitted by Chris Gilland on Tuesday, May 12, 2020

I believe the first person that responded here, who stated that there was a message within the Bard app from Don Olsen about this... I tell ya, I'm an extremely, and I do mean, extremely extremely advanced iPhone/Voiceover user, and I looked left and right, up and down down and up, right and left for that message, and I don't see it anywhere. I don't even see it when going to browse bard website from the get books tab. Even on my PC, and also on my mac, I don't see it. I even tried logging in with firefox on my Ubuntu-Mate Linux machine, and even there, I don't see it. So, where on earth this individual saw this message is beyond me! I'm not doubting them. I'm definitely not. I'm only saying neither I, nor anyone else seems to have seen it, so I find it a little weird that this one person saw something of sort. Usually if there is a message there, until you dismiss and acknowledge that you read it, it's usually pretty bam! Hitcha in the face. You'd think, if it were there, I'd have seen it, unless it was removed before I had the chance to see it, although you'd not think they'd do that until the issue was proven to have completely been resolved.

I dunno folks. I'm not doubting anyone up here who's commented, but admittedly something's just not quite adding up here.

Submitted by Justin on Tuesday, May 12, 2020

I got ya Chris. I don't see the message either. I've looked everywhere as well, but if there's a message, i don't see it anywhere. Normally, I just add books to my wishlist with bard on my mac, then download them with my phone and victor stream later on.

Submitted by Chris Gilland on Tuesday, May 12, 2020

Yeah, Justin... It's looking like most likely that's what I'm going to wind up having to do. That really stinks, but oh well, such is life I guess. Hopefully, they really indeed *do* know about this, and will get it fixed. I mean, they should... I reported it, but being told we can't really do anything since we can't reproduce it. I mean, what the heck? Others clearly have reproduced it, so, what gives? This is ridiculous!

Submitted by Rixon Smith on Tuesday, May 12, 2020

Sorry for adding to the confusion, I was actually referring to the bard application itself. They recently tried to complete some upgrades to the bard service, but were not able to complete this process. Those of you who are busy complaining about this might show some personal initiative as well, and contact the national Library service. There is a link for you to use to send an email at the bottom of the webpage on the login page itself, the more emails they will receive the quicker this will be resolved.

Submitted by Chris Gilland on Tuesday, May 12, 2020

Rixon, I can't speak for others, but, with all due respect, and BTW, I'm not publicly about to get in a ciber war flame up here with you, but For Christ sake, dude, quit assuming things! Who ever up here stated that they were not reporting this directly to Bard. Further, who ever said we were complaining. We're simply pointing out an obvious flaw that we're finding. Further, I know exactly that you were talking about the app, not the website, as, based on comment responses here, I'm sure do others as well. Though I appreciate your help, please don't read between the lines here nor get me wrong, what I don't appreciate one bit is you referring to us as complainers! I mean, god damn! Do we not have a right to voice an opinion here? Jeez! Cut us a little slack, will ya, Sir?

Submitted by Rixon Smith on Tuesday, May 12, 2020

In reply to by Chris Gilland

You may choose to call it pointing out flaws, but they are still legit above complaints. If you’re going to be picking floss, I don’t appreciate being cursed dad through this form. If you persist I’m doing this I do have a contact Michael Hanson directly and I will issue a complaint if you ever curse at me again through this form. Also, I was not running through the lines. It came across to me directly and there might be a little bit of confusion as to whether people were talking about the Bard website or the application itself. The last thing is, people should have been using the email at the bottom of the login screen for the barge service itself and contacting the library service itself. If that’s too much to expect people what you all have iPhones and computers.

Submitted by Rixon Smith on Tuesday, May 12, 2020

Hello Rixon,

You are right - Don Olson put up an alert Friday night explaining the problem. NLS staff is working to fix it but are having trouble. When they do, Don will put up another alert.

Thanks for reminding people about the alert. You could also remind them that the rest of the app is functional, so you can download books through things like Recently Added and also use the new features that allow you to find and download books by the same author and in the same series or subject as books you already have. Information on how to do this is in the user guide; to find it, choose Bookshelf, then Help, then User Guide.

Thanks for asking and for sharing good infomration.


NLS BARD Technical Support
e-mail: NLSDownload@loc.gov
Read the BARD FAQ at:

Submitted by Chris Gilland on Tuesday, May 12, 2020

Rixon, thanks for that forwarded message, and just for the record, I apologize for my last Applevis response publicly to you. I still do feel like you saying we are complaining was a bit harsh, and a bit over-reactive, however, that said, I didn't exactly react the best either to your message, so I'd publicly like to apologize. I've had a really really stressful morning, and I guess the bee got in my bonnet. I shouldn't have snapped like I did though. that is no excuse for my reaction. I hope you'll accept my apology. As I said, I appreciate the help. I've not heard back from NLS yet, but that's heartening knowing that they are aware of things. I wonder why even in the app, I never saw that message? That's totally weirdness.

Anyway... again, thank you for your help.

Submitted by Chris Gilland on Tuesday, May 12, 2020

I never meant to imply that they weren't good people at what they do. I'm sorry if it came across otherwise. Am I annoyed? Yes, but, that doesn't mean I doubt their credibility.

Submitted by ray h on Tuesday, May 12, 2020

I almost exclusively use my iPhone X and the Bard app. Since the weekend, when I open the app and try and go to the Bard site to search for books, I get the log in screen. Using my keychain, I enter the username and password for nlsbardloc.gov which logs me in and I'm able to use all the features. Exiting the app keeps me logged in, but if I close the app I have to repeat the log in process. Not bad at all, but not as nice as always staying logged in.

Submitted by Chris Gilland on Tuesday, May 12, 2020

Ray, that's exactly what's happening here down to a T. If I made it sound slightly different, I apologize. Yes. That's precisely what is happening here.

Submitted by gregg on Tuesday, May 12, 2020

on the signin page that comes up when selecting browse bard, tapping on get app from the app store appears to act like the phone is an android device. If anyone comes up with the same result, reporting this may help them track down the problem.

Submitted by Cory K on Tuesday, May 12, 2020

This is a problem that crept up after some work was done over the weekend. There is no timeline for restoration. I'll update everyone when it is fixed.

Submitted by vBeckles on Tuesday, May 12, 2020

I believe the notification came as a push notification. Or at least that is how I received the information.

Submitted by Chris Gilland on Tuesday, May 12, 2020

Aaah! That would explain it! I'm horrible admittedly at checking notifications. Yeah, I know, I know, you'd think me being such a heavy iOS user, I'd do so, but when you have over literally speaking 350 apps on your phone, that's a leetle hard to do efficiently. LOL!

Submitted by Matthew Whitaker on Monday, August 31, 2020

I also have an iPhone 11 Pro Max and I'm running the latest version of IOS and don't have this issue.

Matthew, this was an older post of mine, if you look at the original publish date. This actually *was* indeed an issue, and the NLS did acknowledge it by everyone having the issue at that time, however, since then, an update was pushed which has had the problem now fixed for about 2 or so months. Sorry for the confusion.

Submitted by Holger Fiallo on Monday, August 31, 2020

Just did what you did and no issue. Using 11 pro max, iOS 6.1.

Submitted by Chris Gilland on Monday, August 31, 2020

Wait... iOS 6.1? Are you sure you didn't mean 13.6.1? I didn't even think Bard Mobile would run on an iOS build that old!

Submitted by Holger Fiallo on Monday, August 31, 2020

In reply to by Chris Gilland

I did not have my coffee when I responded. 13.6.1