Is there a way to stop voiceover from saying running shortcut, when a shortcut runs?'

Forum
iOS & iPadOS

Hey all,
I have a couple of automations set on my ios device. However since I have 1 ios device and you cannot share automations between devices, only shortcuts, I have each automation running a shortcut. However, when the automation runs, lets say the automation is I get the time automatically announced at 12 o'clock, before the automation with the shortcut runs, voiceover will announce, running shortcut, and the shortcut runs right when voiceover speaks, preventing me from hearing the actual text, in this case the time. Is there any way to stop voiceover from announcing each time a shortcut runs and just have the shortcut run automaticly without any prior voiceover interruption? Thanks for any help.

Options

Comments

Submitted by DrewWeber on Wednesday, July 28, 2021

You may try adding, running shortcut, to The pronunciation dictionary if you can copy exactly the format of what voiceover says with a three finger quadruple tap. Then in The field for what voiceover should actually speak, just put a dash or some sort of punctuation that hopefully voiceover will not read. This will silence voiceover from ever reading this string in any application.

Submitted by Yvonnezed on Thursday, July 29, 2021

You certainly wouldn't be the first person to complain about those notifications every time an automation runs, it's one of the biggest complaints on the Shortcuts reddit group, ☺️. It's one of the few notifications you can't turn off. The theory is it's some kind of security feature to make sure automations can't run on an iOS device without you knowing.

I think there's some kind of work around that can disable it using screen time, but it's never actually bothered me enough to look into it.

I did look into that and got it to work. Basically you go into screen time, into the notifications area, and after getting at-least one notification from the shortcuts app, go into the notification and turn the allow notifications toggle to off. Although I really don't gaet why didn't apple didn't allow a toggle of the shortcuts app in notifications centre settings... but this method works anyhow, it just takes a couple more steps.