TextReplacement issue since iOS12

iOS & iPadOS

Hi there.
I am a massive text replacement user, and since iOS 12 some of my shortcuts do not expend anymore. It seams like a length problem. The short ones expend but the expression cannot be longer than 100 characters. Does anyone have this?



Submitted by Bruce Harrell on Sunday, November 25, 2018

Hi. I've had problems related to text replacement when it got too filled up. The more I filled up my text replacement data base, the worse the problems became.

How much have you filled up your text replacement data base? You might get a total number by clicking edit and go to the very bottom of your list of replacement definitions. If you are over 5,000, that might explain your problem.

The fix is a bit trickier. Unfortunately, I don't remember what the commands are, but Apple can tell you. They are the commands to completely wipe your text replacement data base. The only alternative at present is to delete your text replacement definitions one by one until you get below a certain threshold, at which point your remaining definitions should all work correctly.

Hope this helps.


Submitted by jprykiel on Sunday, November 25, 2018

Hi Bruce.

38 is all I have. But were you talking about the iPhone or the Mac? I am not using text replacement on the Mac, and the iPhone doesn't have a definition number display as far as I know. It appears all my definitions are working well, except for one which is 302 characters long. I have tried deleting it and reentering it, but no luck, and the exact same definition/shortcut is working on one of my friends phone. Same iOS, the only difference is that mine is a 7, and his is an X.

Any idea?



Submitted by jprykiel on Tuesday, November 27, 2018

Hi there,
I made a new discovery, but an intriguing one. My issue has something to do with flick type, but does not disappear when flick type is removed from my iPhone.
Let me explain. The problematic definition expands only when using flick type keyboard. As some of you may know, since a few versions, flick type now handles text replacements and so interacts with them in a way.
But even after removing flick type from my iPhone, and I don't mean killing the application, I mean really, deleting it, this particular definition will not expand with the standard keyboard. I even restarted my iPhone after deleting flick type but this did not help. This seems to happen with all definitions of more than 100 characters. What else?
Best regards,

On my iPhone 6S, longer string portions of new text to be substituted is no longer happening, so well done for finding this fault!
I have noticed for a long time on certain web sites, where they want an email address and password entering, my email address short-text wont' expand to the full email address.

Probably related to how they've implemented the web page login form rather than IOS in that case, for security purposes.


Submitted by jprykiel on Thursday, December 6, 2018

my issue has been solved in iOS update 12.1.1.
Best regards,