Temporary notifications don't disappear

Forum
iOS & iPadOS

Hello!
I am noticing that temporary notification banners often don't disappear on their own after a few seconds, forcing me to close them via rotor action.
Also, when VoiceOver focus lands on such a notification banner, my rotor language resets to standard.
So, all in all, I need to tap the notification, swipe up to select the closing action, double-tap to actually close the notification, then fiddle around with the rotor to re-adjust my language. A lot of work just because someone decided to text me.
What can I do to make sure temporary banners are indeed temporary? And how can I prevent random notifications from messing with my choice of what language VoiceOver speaks?
All the best,
Endarion

Options

Comments

Submitted by LaBoheme on Monday, November 18, 2019

not a few seconds, notifications won't go away, period. i waited for 2 full minutes, just to test it out. a few things to consider.

1) the notification is indeed there, not just vo plays trick on you, i OCR it, so i know.

2) at first i thought this should be fixed soon, because sighted users would be bugged by this, too.

3) there doesn't seem to be any discussion about this, so i think this happens only when vo is on. i have not tested with vo off, but i'm very sure this is the case.

4) so this is a vo problem, good luck get it fixed, maybe till ios 14.

Submitted by Kerby on Monday, November 18, 2019

One workaround is to lock the screen, then unlock it again and they go away, that is until the next one comes in.

Submitted by Cliff on Monday, November 18, 2019

Another workaround is to put the VO focus on the notification and flick up a few times through the actions menu in the VO rotor until you find remove, and then just double tap to remove the notification.
But I agree, this bug has been present and pretty annoying even from the early stages of iOS 13 betas. And it is as someone mentioned above most likely something that only happens while VO is running.

Submitted by Missy Hoppe on Monday, November 18, 2019

Yes, there are work arounds, and this is a relatively minor bug in the grand scheme of life, but I'm surprised that it hasn't been given any kind of priority. This, along with some incredibly frustrating focus issues I have been experiencing makes me wish that I would have gone with my initial instinct and skipped iOS 13. Nothing I've found in the update has made it a must have, and I think that on the whole, I was alot happier with iOS 12. What's done is done, however, and all I can do now is hope for better things in the future.

Submitted by KE7ZUM on Monday, November 18, 2019

If anyone needs to reference Feedback · FB7350755 you have my permission to do t so. I reported this apparently October 5th. And it's not ben fixed in a month. No response from apple as far as I can see. In fact I get this when I look at my feedback. Resolution: Open which means no one else to mmy knowledge has reported this.

Submitted by Luke on Monday, November 25, 2019

Yes, experiencing this as well on my iPhone 8. Annoying but fortunately not a show-stopper. As someone else pointed out, I imagine it's got to affect sighted users too so I'm surprised it hasn't been resolved yet.

Submitted by Victoria F on Friday, November 29, 2019

Another workaround someone taught me is to touch where the notification is and swipe up with three fingers. This way you don't have to invoke the rotor at all and it is pretty seemless. I hope the bug gets fixed in a future iOS update, but for now, this for me is easier than using the rotor to dismiss the notification.

Submitted by P.A. on Wednesday, December 4, 2019

To stop the issue with banners getting in the way of whatever you're doing I just recently went to settings/notifications and set "show previews" to never". The notifications are less informative, but the last few haven't gotten in my way, either.

Submitted by charles on Wednesday, December 4, 2019

I have had the issue of notifications being spoken once a minute by Voice-Over since I began beta testing 13.0, and the bug still persists. I have sent a report using the report feature with each new beta, and it has still not been resolved. The way that I get rid of the notifications is to do a single finger swipe down to the "dismiss" button and double tap with one finger. This gets rid of the notification.

Submitted by J.P. on Wednesday, December 4, 2019

I have also reported this in multiple beta feedback. The swipe works easily enough. It’s really annoying now at the holidays. Being alerted for every shipment update. Along with store alerts wanting to sell you more.

Submitted by Roxann Pollard on Thursday, December 5, 2019

Since iOS 13 was released, the Simple line, "Do Not Disturb", seen on the lock screen has grown to a long, and very annoying sentence that states something like Do Not Disturb, You will not receive calls or notifications while Do Not Disturb is active. I looked at the settings for Do Not Disturb but seen nothing to change this long message. I thought about using Pronunciation to shorten the sentence back to simply Do Not Disturb but I haven't tried it. Does anyone have any suggestions?

Submitted by Kerby on Thursday, December 5, 2019

You can swipe up or down to clear the do not disturb message and it should go away, at least until you turn off dnd and turn it back on again.

Submitted by Jeff on Thursday, December 5, 2019

Actually, I'd like to turn off the Do Not Disturb notification altogether, but I cannot find where to do that. Does anyone know how to do it if it's possible?

Submitted by KE7ZUM on Friday, December 6, 2019

I don't remember it beientg possible. I actually don't mind it as I was in DND during work and was wondering why I was missing calls. Woops?

Submitted by Roxann Pollard on Friday, December 6, 2019

I have utilized this method but as you said it's only temporary. I like the basic statement of DND but this long sentence has become very annoying. I would just like to have the simple DND statement and nothing more. After all, the explanation of what DND does is shown in the Do Not Disturb Settings anyway. I can't understand why they need the full explanation given on the simple notifications area. Uggg.