Sync contacts with gmail?

Forum
iOS & iPadOS

Hello guys!
I formatted my iPhone and connected my gmail and iCloud accounts. He ended up mixing the contacts in his accounts.
I did a cleanup on my contact list and would like to send this new list to the gmail account.
How can I do this?

Options

Comments

Submitted by Tyler on Wednesday, August 23, 2017

Member of the AppleVis Editorial Team

If you have contacts enabled for your Gmail account in Settings>contacts>accounts, the iCloud and Gmail contacts should automatically sync.

HTH

Submitted by Kronos23 on Thursday, August 24, 2017

Hello, thanks for the tip, I used to set up my Gmail on my iPhone by going to Other, which only had the option to sync your Mail and Notes, but nothing else. I deleted my Gmail and when adding the new account, instead of choosing Other, I chose Gmail and turned on the Contacts and Calendar toggles. But my question is this, when I go to my contacts and only display my Gmail contacts, then when I view the list of contacts, they all disappear. They only show when I display all my iCloud contacts. How can I be sure that my iCloud contacts sync to Gmail as I also have a Galaxy S6 and have always wanted to find a simple way of syncing all my contacts from my iPhone to my GS6? So that way, when I make a change to a contact on my iPhone, the change can sync over to my Gmail and be updated on my GS6.

Submitted by Tyler on Friday, August 25, 2017

Member of the AppleVis Editorial Team

The only other suggestion I have is to make sure SSL is enabled. To do this, open Settings>Contacts>Accounts and double tap your Gmail account. Then, double tap account>advanced and make sure, "Use SSL," is on. It's usually on by default, but it may be a good thing to check.

HTH

Submitted by Kronos23 on Friday, August 25, 2017

SSL is already enabled.

Submitted by Kronos23 on Friday, August 25, 2017

I'll try and look on the web to see what I may be doing wrong. It's no worries, if I can't get it to work, then I'll just turn it off and leave it be. Thanks for your help though, very much appreciated.