Stop iOS from automatically entering the iCloud mail inbox when opening the mail app

Forum
iOS & iPadOS

Is there a way to stop the iPhone from automatically going into the inbox for my iCloud mail when the app is first opened?
I would rather open the inbox's of my email accounts manually. I hope this makes sense.

Options

Comments

Submitted by mehgcap on Friday, May 23, 2014

Member of the AppleVis Editorial Team

The Mail app will remain wherever you last had it. If your iCloud mailbox was the last one open, you are placed back there; if you were viewing an email, that email is the first thing you'll see; and so on. The only reason it would return to your iCloud mailbox is because that is the last box you were checking. If it has been a while, Mail usually defaults to the "all inboxes" mailbox, which shows a unified view of all the messages in the inboxes of all your accounts. Just go back one level from there, and find the "accounts" heading; open the account you want, then go into its inbox.

I want it to open to the list of inboxes, and not enter any inbox automatically.
I went into my mail app, and clicked the back button in the iCloud inbox, and went back to the list of accounts / inboxes, and the next time I open the App, it returns to the iCloud inbox. I don't even use my iCloud account for email. It was put in the mail accounts list when I setup my phone.

Submitted by Michael Hansen on Sunday, May 25, 2014

Member of the AppleVis Editorial Team

Hi Will,

While I don't know of any way to have Mail open to the inbox list, you can turn off iCloud e-mail if you do not use it:

1. Go into Settings
2. Swipe down to iCloud and double-tap.
3. Swipe to "Mail" and double-tap to turn this functionality off. A pop-up will appear, saying that downloading of iCloud mail is being disabled; the pop-up will disappear automatically.
***Note: You may have to do the above steps twice. I've had to do several device restores lately to troubleshoot an issue, and almost all (if not all) of the times I did a restore-as-new-device, I had to disable iCloud mail twice before the change actually took effect.

Did you try backing out until you cannot back out anymore? Afterwhich you are presented wiht all of your mail boxes and accounts. If so and this is still going on to a random mail box on mail restart I say you have some corrupt thing that is keeping the mail plist file or how ever it works on ios from saving.

Submitted by Will C. on Friday, June 13, 2014

Marrie, I have tried that as well.
I had just reset my phone to factory defaults like a week before I noticed the problem, so I don't think it's a corruption issue.
I will have to contact Apple and see if it is normal, or if they can tell me how to fix it.

Submitted by KE7ZUM on Friday, June 13, 2014

Well I know it's not normal as I have 2 icloud accounts and this never ever happens to me. Yeah something is definatly up.

Submitted by Katie on Friday, August 7, 2015

If you have the latest update to iOS, I think it's 7. Then open your mail, go to the "mailboxes" screen, then in the upper right corner, tap "edit".

Now scroll down to where it says "accounts" then put whichever account you want the phone to open as the first listed account.