Skip Link Issue

Forum
iOS & iPadOS

I apologize if this is an old issue but I usually do native app and now they have me looking at mobile web and hybrid apps. I seem to have an issue with the Skip Link on a mobile web using an iPhone and iPad. I can activate the Skip Link and it sends me to where I want to go. When I swipe to go to the next element it takes me to the next section, region or container on the page. I don't seem to be able to Swype to that next element but I can do it by Explore by Touch. I notice the same issue on this site, is there a work around or bug that I have to live with?

thanks

Options

Comments

Submitted by Dalia on Tuesday, May 10, 2016

This is a known and long-standing VoiceOver problem on both iOS and OS X. It doesn’t appear to be consistent, but I have personally seen this problem in various forms on many, many sites.

Submitted by dvdmth on Saturday, May 14, 2016

Club AppleVis Member

One problem I have always had with VoiceOver involves links that point to the middle of a webpage, either the currently viewed page or a different page.

If a link goes to the middle of the current page, VoiceOver generally follows the link properly, but then has trouble navigating from that point onward. If a link points to the middle of a new page, the page will load and scroll visually to where the link is pointing, but as soon as the page has completely loaded, the page suddenly scrolls back to the top and the VoiceOver focus is placed at the beginning of the page. This problem often happens on message boards which will point you to the first unread post in a topic.

I don't know if this is a VoiceOver bug per se, or if the Safari engine is to blame. Either way, it is quite annoying when you are trying to navigate a website that uses these kinds of links.

Incidentally, I don't think I ever used the skip link at the top of a webpage. I either use touch navigation to get to the main part of the page, or I will navigate by heading. These methods work pretty much anywhere, regardless of whether or not a skip link is present. On the few sites where heading navigation doesn't work, I don't recall ever seeing a skip link either.