Setting up Filters for Parcel in Gmail

Forum
iOS & iPadOS

I followed the steps to create filters for Parcel for my Gmail accounts, but something clearly is not right. I am not getting things filtered even though I followed the directions on Parcel's website. What could I have done wrong in my Gmail account, and how do I get the filtering to start working correctly?
Jordan

Options

Comments

Submitted by kevinchao89 on Wednesday, January 4, 2017

If on:
* Mac: inbox.google.com
* iOS: Inbox by Gmail on App Store

THese types of bundles happen automatically, so no need to make filters, labels, etc.

Submitted by Jordan on Wednesday, January 4, 2017

Not sure what you are talking about because here are the instructions for Parcel to work.
1.Sign in to your Gmail account.
2.Open your account settings:

3.Select “Forwarding and POP / IMAP” tab.
4.Add your Parcel Email address as a forwarding address.
5.A confirmation code will be sent your Parcel Email address. Parcel will receive the code on your behalf and send it to your registered account email in Parcel.
6.Enter the confirmation code in Gmail settings.
7.Make sure that 'Disable forwarding' option is selected.
8.Find a delivery email from Amazon or any other merchant in Gmail.
9.Select ‘Filter messages like this’ from the options:

10.If you are creating a filter for Amazon delivery emails, you don't need to enter any other filter parameters since Amazon always sends delivery emails from only one address (e.g. ship-confirm@amazon.com in the US). For all other merchants we encourage you to specify additional filter parameters to avoid forwarding emails that don't have delivery information. For instance, if you are creating a filter for eBay US, specifying ebay@ebay.com as a filter address will not be enough. You will also need to add 'SHIPPED' to the subject filter parameter.
11.Click on 'Create filter with this search'.
12.Enable 'Forward it to' and select Parcel Email from the relevant list.
13.Click on 'Create filter'.

I still cannot get the filters to work for some reason.

Submitted by KE7ZUM on Wednesday, January 4, 2017

You need to add the correct shipping addresses. You need to find those out by reading headers. It worked for me the first try as I jut coppied the shipping@amazon.com or what ever that address was.

Take care.

Submitted by Jordan on Wednesday, January 4, 2017

All the addresses are correct. So, that is not it.
Jordan

Submitted by Samington_Squire (not verified) on Sunday, January 8, 2017

Hey,

I also experienced this issue when setting up the Parcel email filter from my Gmail account.

From my experience, it just won't work on shipment emails already in your inbox, even if you tick the box to apply the filter to X number of matching conversations. All I could do was wait until I needed to order something else from Amazon. Even before my iPhone picked up the dispatch email, I received a notification from Parcel to inform me that the delivery had been added.

As such, it would seem that this only works on newly-received shipment emails at the moment.

I was previously in contact with the developer and apparently he's in the process of implementing a feature whereby a tracking link can be added directly to Parcel. This would nicely supplement Parcel email, especially when ordering from a merchant for the first time, when we probably won't know the address from which shipment notifications are sent.

Anyway, just my experience.

Submitted by Jordan on Sunday, January 8, 2017

I hope that gets implemented. That is the one feature of Ship-Rack that was nice until it quit working and needed to be replaced. I will see what happens the next time I order something because I have set filters up and hope it works.
Jordan

More Like This