Safe to Update WhatsApp

iOS & iPadOS

The issue has been resolved by itself for me. And since many of us aren't experiencing this issue, there's no need for causing more panic among the community. The original post is as follows:
Do not update to the most recent version of WhatsApp. It'll make VoiceOver not to provide any typing feedback, even if you use braille screen input.

I thought it had something to do with my phone itself and restarted my phone. I then tried typing something on WhatsApp with the issue mentioned above not resolved.



Submitted by Gar on Monday, April 27, 2020

There is a reason why I don't update big name apps... like, ever.
Improvements and bug fixes tells me absolutely nothing, for one. If you're not going to take the time to tell me what's changed I'm not likely to take the time to care. So if what I have works, why mess with it? Plus, on a personal level I have issues with WhatsApp being owned by Facebook, the poor privacy practices they have. But... that's a bit beyond here.

Submitted by Ramy Moustafa on Monday, April 27, 2020

ّيّّI Updated before seeing this post, and it is working with no issues. using latest ios13 on iphone 8 plus.

Submitted by Apple Khmer on Monday, April 27, 2020

There are other options that are accessible and secure such as Signal and Tox.

Submitted by Dave Nason on Monday, April 27, 2020

Member of the AppleVis Editorial Team

No problem here either. Perhaps just a glitch on your phone.

Submitted by Melissa on Monday, April 27, 2020

Unfortunately, I did update, and I have run in to the same problem. As I type, I am not getting typing feedback even with Braille Screen Input. I did report this, so maybe it will get resolved.

Submitted by SplendidFault on Monday, April 27, 2020

I'm glad that no-one else other than I and Melissa are experiencing the issue so far. I hope that they address this very quickly, as typing feedback is an absolute must to use WhatsApp and its counterparts.

Submitted by ming on Tuesday, April 28, 2020

I have been experiencing the same issue.
but, I think it fixed in the background
it is working fine now.

Submitted by KE7ZUM on Tuesday, April 28, 2020

No issues here. I receive all feedback via BSI, typing, bluetooth, you name it, it works. Dunno what the issue could be for you guys. Mayb e it will just fix itself.

Submitted by Kevan on Tuesday, April 28, 2020

What phones are you guys on who are having problems?
I have no issues with my iPhone 8 running the latest iOS.

Submitted by Gerardo on Tuesday, April 28, 2020

Using an iPHone SE 2016 model with latest iOS 13.4.1, no problems here with my Whatsapp using Braille-input. good luck for those who have it! Hope it gets fixed soon. What a bummer indeed! Have you guys tried closing Whatsapp from the App-Switcher and opening it up again?

Submitted by kool_turk on Tuesday, April 28, 2020

Using a 6S, and everything is working perfectly here.

Submitted by chris R on Tuesday, April 28, 2020

Already updated and no problems here, although I do use dictate most of the time so less likely to see that problem quickly.

Submitted by Melissa on Tuesday, April 28, 2020

I am using the iPhone11 Pro, and am running the latest iOS version of 13.4.1, and have the non-typing feedback. Glad for those who are not having this issue though.

Submitted by SplendidFault on Tuesday, April 28, 2020

Wow! The issue seems to have gotten fixed. I had done everything that I could think of, including killing the app and starting it again, restarting the phone, etc etc with no luck whatsoever. Then, it fixed itself, as if some magic happened. The world of electronics is unpredictable sometimes.

Submitted by alex wallis on Tuesday, April 28, 2020

No issues for me either, maybe this thread should be deleted so it doesn't create falsepanic with people and give out misleading information. I know the original author had no intent to mislead, but based on the fact that it seems to be working maybe having this thread isn't a good idea.

Submitted by Melissa on Wednesday, April 29, 2020

Well, for those who have had trouble with the latest update, I did resolve this. This is definitely weird, but on my iPhone11 Pro, I had Face ID enabled. I disabled it, and everything now works normally as it should with the typing feedback. I wouldn't think that that would have anything to do with it, but there you have it! I had tried uninstalling it and reinstalling it, but that didn't help. Thought I'd share.

Submitted by mority on Wednesday, April 29, 2020


Another problem is that the two finger swipe up to go to the top of the screen doesn't work anymore for me in whatsapp. I also have the non typing feetback, but I can do without for a while though, i use direct touch typing and I'm pritty good with that.

The hole problem seams to be related to some settings that the users have on their phones, I'm currently investigating what they could be.

Greetings Moritz.

Submitted by SplendidFault on Wednesday, April 29, 2020

The issue is back yet again on my iPhone 7, running iOS 13.4.1. I also experience the scrubbing issue that Mr. Moritz described.

Submitted by sechaba on Sunday, May 3, 2020

Unfortunately I am also experiencing the same problem with Whatsapp on Iphone 11 ProMax. No typing feedback whatsoever. Tried with both BSI and traditional way of typing.

Submitted by sechaba on Sunday, May 3, 2020

Whoever suggested disabling the require face ID on the whatsapp unlock is soooo brilliant, intelligent and clever. I disabled it, and whallah, my typing feedback is back again. Even the four finger single tab to go to the top op whatsapp works perfectly again.

Submitted by NavyDude899 on Saturday, July 18, 2020

I have had this issue for months now but I turned off Touch ID and it solved the issue. Typing Feedback is back again.

Submitted by Igna Triay on Saturday, July 18, 2020

I had this bug... it seems it was caused by the touch ID / face ID option to unlock whatsapp, as after disabling this setting whatsapp worked once again as normal.

Submitted by Karina Velazquez on Wednesday, July 22, 2020

Hi, I started having this issue since I've got my new iPhone 11. I'm still using my iPhone 7 and with this last one, I have never experienced this problem.
I tried killing the app and reinstalling again, and this solved the problem for the first time, then, don't know when, it appeared again.
I think in deed we have to make noice for this with the app developer, the rare thing is that with my iPhone 7, nothing happens, and just with my iPhone 11.