A possible bug in IOS 8.2 concerning App Store and updates

Forum
iOS and iPadOS

Hi everyone,
so tonight I started noticing a very strange problem in the app store. It said that I have three updates, but when I try double tapping on the updates tab, I see the the update all is dimmed. Even stranger still are the updates to the apps. I can see the three app updates, but beside each I see an open button, not a update button. However, I still see that I have three pending updates. Has anyone else seen this? This on IOS 8.2 on an iPhone 6 plus. I have tried restarting the phone, and signed out and back into my apple ID.
Thanks

Options

Comments

Submitted by Clare Page on Friday, March 27, 2015

Hi! Reading this makes me wonder if you have set your i-device to download app updates automatically, as I have: if that's the case, this isn't a bug. If automatic app updates are enabled, the Update All button will be dimmed while an update is being downloaded, and any updates which have already been downloaded will have an Open button when you swipe right from the app name, rather than a Download button. I've used automatic updates ever since they were introduced, as before that I always updated every app anyway, so I admit I'm no longer 100% sure how manually updating apps in the IOS App Store works these days. If you prefer to manually update your apps, I'm sure someone else will be able to tell you if this is working right or not under IOS 8.2.

Submitted by John Lipsey on Friday, March 27, 2015

I have the same experience. I never use automatic updates, because I prefer control over what gets updated when, especially if updates introduce accessibility issues. Interestingly, I didn't notice this bug or whatever it is until yesterday. App store worked fine under iOS 8.2 until then.

Submitted by Jesse Anderson on Friday, March 27, 2015

In reply to by John Lipsey

I too have all of my devices set to manual updates after a few apps have broken accessibility in the past.

This isn't an IOS 8.2 bug. I have run into this from time to time since IOS 7.

Based on trying different things, I think it probably has something to do with the connection to the app store. for some reason, one or more apps may still be downloading, or your device thinks something is downloading. It may also have some trouble connecting to the app store.

When this happens to me, I just close the app store via the task switcher. Open the store again, and most of the time, the Update or Update All buttons will be clickable again. If it's not urgent, I just let the device do its thing, and eventually the updates are downloaded on their own.

Submitted by Usman on Friday, March 27, 2015

I also have automatic updates disabled. Like I said, this was happening to me even after restarting the app store, signing out and back in to my Apple ID, and restarting my phone. I wonder if its a bigger issue?

Submitted by KE7ZUM on Friday, March 27, 2015

This also started happening to me since yesterday. Looks like a server glitch that should be fixed soon. I also have auto updates off to save my battery. I've tried rebooting, killing and relaunching the app switcher and Nothing has worked, even restarting vo has not worked this time. So this leads me to a server issue. The work around is to synch with iTunes.

Take care.

Submitted by charles on Friday, March 27, 2015

This is one more reason why iTunes should be used to get updates when your phone is connected to your computer. Not only is the process more doable, but you have screen readers to tell you what's going on during the process, and, more importantly, a backup is automatically made in case there is a screwup. It is more reliable than just getting updates using only your phone. For those who say that they don't like iTunes, I suggest that you do learn to use it. If you think it's too hard, remember when you first got your iDevice? It took a bit of learning, time and patience to get to use it, right? How about now that you've gotten used to it? Learn iTunes. It's worth the effort.

Submitted by KE7ZUM on Friday, March 27, 2015

Actually for me no back up is made when I use itunes. I learned that in like 2 hours how to use itunes but then again I'm pretty good at learning how to do most things. and for ios, it was easy. I learned most of the functions in like 24 hours.

Btw I think the server issue is fixed as I jut updated an app successfully this morning so applie might have known about and resolved the issue.

Submitted by Usman on Friday, March 27, 2015

Its not fixed here. I still see three updates pending, but the update all button is still dimmed.

Submitted by splyt on Friday, March 27, 2015

Not using itunes. I am good at itunes but do not like the philosophy behind it and do not like to be forced to use it so I won't do it unless I am strictly required to.
I'll keep updating the old way I mean I will if Apple can keep its software without bugs, something they're having each day more trouble to do in last years.

This is not accessibility related so let's wait and see when they're gonna finally fix it.

Actually do we know it's accessibility related or not? Did you confirm this with sighted people with out voice over to make sure it's apple's fault and that they broke something?

Submitted by Tom Shill on Friday, March 27, 2015

I also noticed this bug after trying to update Twitter on IOS 8.2.
The way I fixed it is to reset my phone by pressing and holding the "home button and the "power button for afew seconds allowing the phone to reset.
That did the trick.
I was able to do a proper update of the Twitter app and now all is right with the world.
Hope this helps.

Submitted by Usman on Friday, March 27, 2015

Its working for me now. I didn't have to do anything special. I guess it was in fact a server problem on apple's end.

Under settings, I went to iTunes and App Store, and I unclicked the apps and update buttons.
Then I went back to the App Store and clicked the update button in the bottom right corner 10 times fast to reset the page. When you do this, immediately after you click the update button 10 times, it should say "update" under pending/available apps (next to the apps that won't download) for a split second, but then it will go away. What I did, was click the update button again 10 times fast, and with my other hand, would click in area where it would say update multiple times, so you will catch the update button, instead of the open button. Sounds strange but this fixed my problem.

Submitted by Toonhead on Thursday, June 16, 2016

You may want to consider upgrading to iOS 9 unless you're doing the jailbreaking thing.