Native iOS mail app weirdness

Forum
iOS & iPadOS

Around a week ago I was browsing through my gmail account using the native iOS app and somehow managed to hit the "compose" button by accident, which of course started a draft email. I deleted the draft by double-tapping the "cancel" button and confirming the deletion, but noticed after returning to my inbox that I still apparently had a draft in progress. Repeating the above actions accomplished nothing, so I went into the "drafts" folder and manually deleted the email. At this point, even though the "drafts" folder was clearly empty, I was still being told that I had a draft in progress. When I opened up the supposed draft notification, I wound up with another copy of the blank email in my "drafts" folder. I've spent the past week trying every variation possible of the standard deletion commands, but none of them seem to be able to make this thing stay permanently gone. I tried getting rid of it via the native mail client on my Mac... no dice. I logged into Gmail.com and cleared out all drafts ... nope. Does anyone know what might be going on here and how I can squash this annoyance for good?

Options

Comments

Submitted by Mister Kayne on Monday, December 21, 2020

Settings; Mail; accounts and click on the account you want this change to take place with. Tap on the account name and a few swipes right you should find how mail items are treated in this account. Ideally the drafts should go to the drafts folder and the deleted items should go to the Trash folder. I suggest this from my experience of using Gmail with the native mail app. on IOS 14.3 if you are using Gmail you might want to also check the settings for Gmail on the web after signing into your mail account online

Submitted by Frankd on Monday, December 21, 2020

I only recently switched from iOS12 to iOS14 so I don't know how long this bug has been around but I have this problem also.
To get rid of draft mails I simply enter a bogus address into the "To" field and send the mail. Problem solved temporarily.
If others are experiencing this problem then we should report it to Apple FWIW.
Cheers

Submitted by Ravenpaw on Monday, December 21, 2020

In reply to by Mister Kayne

Good thoughts! Unfortunately everything seems to be set up correctly both on my device and online, so I'm starting to lean toward the "this is a bug" side of things.

Submitted by Ravenpaw on Monday, December 21, 2020

In reply to by Frankd

I knew that would probably do the trick but I guess I was holding out as long as possible. Oh well, bogus mail it is then. For now.

Submitted by soni on Tuesday, December 22, 2020

I am having the same problem as well. This is not just using a gmail account. For me, it's any account in mail.