my brother cannot install iOS 11.03

Forum
iOS & iPadOS

My twin brother Larry doesn't have a profile set up with Applevis so I'm sending this problem along. He can download iOS 11.03 but when it comes time to install, he gets a message saying cannot install iOS 11.03. What are his options at this point? going back is probably not available for him. He is currently using iOS 11.02. thank You!

Options

Comments

Submitted by SoundSchemer on Thursday, October 19, 2017

What I'd suggest, is for him to reset his iDevice, and reattempt the installation.

Submitted by Lee on Thursday, October 19, 2017

Hi, Maybe he doesn't have enough memory? Maybe worth checking what he no longer needs on the phone and deleting it. It maybe he is only just under what would be needed to install. Then try again. HTH

Submitted by Dawn on Thursday, October 19, 2017

Hi! I agree with Lee. That's happened to me before. I don't recall the amount of storage needed for installation or the amount available on my ipad but it said there was inadequate storage available. Once I deleted some photos that I had downloaded and no longer needed, all was well. Once he deletes unwanted and no longer needed stuff off his phone, if he already has it downloaded, he needs to go back and delete it and redownload the update.

I'm not sure how big the 11.0.3 is, but for me it was I believe 1.01 Gb. if memory serves me. But that was because it had to install the whole update. Because I chose to wait.

If nothing else, maybe have him do a hard reset and if worse comes to worse, have him do a backup and put the device in Dfu. mode.

Also, has he tried updating from itunes? If not, tell him to try that. I cannot give you spicific proceedures on how to do updates that way, as I only do updates via OTA. But, I'm sure you can find them on here and other internet resources. Hope this helps. Wishing your brother the best of luck.

Submitted by Larry Gassman on Friday, October 20, 2017

In reply to by Lee

Hi, It had nothing to do with storage. Not sure why I could not install from the phone, but I was able to do so with i-Tunes. So all is well, and the issue has been solved. Thank you all for your comments.