Major bug with setting appointments with Siri in iOS 8.2

Forum
iOS and iPadOS

Here's one for the bug report section of Applevis.
A friend on twitter told me about this yesterday so I tried it myself and I get the exact same results every time. Note, this bug appears in iOS 8.2, I haven't seen this happen with earlier versions.

To reproduce this bug, do the following...
1. Ask Siri to set an appointment for you. I picked the random hour of 9 AM just for fun.

2. She will confirm that it's the right time and you can confirm once again. I answered no to the question about it being a scheduled appointment, because it was only a test.

3. Siri will now say, uh oh, there seems to be a problem. Can you try that again?
4. Now, go to your calendar and look up the date and time you specified for the appointment, and you'll see that it's been added to the calendar, despite Siri saying there's a problem. I went ahead and deleted the appointment, once again it was a test so it really didn't matter. Has anyone else seen this? It happens every single time I try it.
Thanks.

Options

Comments

Submitted by Malthe on Thursday, March 19, 2015

Hi

The following procedure fixed it for me:
1. Go to settings>general>siri and turn it off
2. Go to settings>general>keyboard and turn off dictation for all languages.
3. Turn off your iDevice by holding down the power button and double-tapping power off.
4. Turn on your iDevice, and turn siri and dictation back on.
Note: You have to turn off the iDevice before reenabling siri, otherwise it apparently has no effect.
Hope that helps

Malthe

Submitted by Ro on Thursday, March 19, 2015

This has been happening for me for awhile now, exactly as you described. I haven't yet updated to 8.2. I'm going to try that fix when my brain is working.

I found this bug in 8.1.3, and contacted apple about it. It happens for me, every time. I will try this possible fix, and see if it helps. Like I said, Apple has been notified of the situation, and I hope there is a fix for this soon.

Submitted by Doctor D on Thursday, March 19, 2015

In reply to by Malthe

I just tried the work around that was mentioned here in this thread, and it did not work for me. I am using and iPhone 6, running I o s 8.2. Sure hope they get this fixed soon.

Submitted by CW on Friday, March 20, 2015

This bug has appeared since my iphone is updated with IOS 8.1. However, the fix didn't work for me either. I'm using iphone 5 with IOS 8.2. Please note the event has been created in your calender although SIRI said a problem to create the event.