language voiceover rotor option dimmed?

Forum
iOS & iPadOS

I have language selected in the voiceover rotor options, but it is dimmed or unavailable. How do I add a language to the rotor such as a Spanish voice or language? and will this just change the tts or will it change the entire interface including the keyboard? If I want to study spanish as a second language, for example, I probably only want to change the tts and keyboard sometimes. How is this done on an iOS device like my iPod touch running iOS 12.4?

Options

Comments

Submitted by Betsy on Sunday, September 8, 2019

For me the problem is that sometimes, okay often, I will inadvertently change my Voiceover voice from the one I have chosen to Samantha by flicking up or down when rotor is at language. I don't like Samantha and so when I do this I have to flick up or down to change back to my preferred voice. When it happens I try setting rotor to something other than language but language is the only rotor option. In an attempt to eliminate this problem I went to my rotor setting to remove language from the rotor. But I found that I could not do this because the language option is dimmed. So I too would love to know how to un-dim language in rotor albeit for a different reason from yours.

Submitted by Maldalain on Monday, September 9, 2019

Adding voice languages is available in Voice Over in Speech settings. There you add rotor languages.

Submitted by Josh Kennedy on Monday, September 9, 2019

I found it, and I also found out how to delete languages. Deleting languages is just turning the rotor to actions, swiping up to delete and double tapping it.

Submitted by Josh Kennedy on Monday, September 9, 2019

When you are on the language you want to delete, just rotate the rotor to actions, then swipe up to delete and double tap it and the language should be gone.

Submitted by Betsy on Monday, September 9, 2019

I'm wanting to delete language from my rotor. Not a language but the language option. I was hoping I could do it using this method but all I get is move up move down and activate.

Submitted by Piotr Machacz on Monday, September 9, 2019

The option in the rotor settings is dimmed because it's not a toggle you can select and deselect. Whether it appears is controlled by whether you have any additional speech languages configured. Under VoiceOver settings in the speech category, delete any languages you're not using as Josh described. Once all of them are deleted, the language option shouldn't pop up when you rotate around your rotors.

Submitted by Betsy on Tuesday, September 10, 2019

Under Voiceover, speech, listed is English U.S. and Samantha. This in spite off the fact that Alex is the one reading to me. I swipe up to activate and Alex is not selected but Samantha is. But she only speaks when I flick up or down when the rotor is on language. To get back to Alex I flick again. He comes back but still it's only Samantha who Is selected. I wonder if I should choose delete on the English U.S. Samantha setting and see if that clears things up.

Submitted by Betsy on Tuesday, September 10, 2019

I did it and it worked. Now Alex is selected and language is not in the rotor. Thank you!

Submitted by Betsy on Tuesday, September 10, 2019

Actually language is still selected and dimmed in the rotor settings. But when I do the rotor gesture it's not being announced by Voiceover so that's all that matters to me.