keychain

Forum
iOS and iPadOS
I inadvertently disabled Keychain when I installed iOS7. (restoring to named phone). I have not found a way to enable it. Does anyone know if this can be done?

Options

Comments

Submitted by MarkSARCH on Saturday, October 26, 2013

Hi I have seen the option to enable or desable keychain under settings just go to Settings app on your iOS device look for iCloud keychain on or off hope this helphs.

Submitted by WildmanJoe on Monday, November 11, 2013

In reply to by Joe Fallin

I'm not sure if I am even understanding how to use the Keychain. if I'm understanding correctly, the Keychain remembers your passwords and such across sites and devices. However, I can't seem to make it work. Here is an example. Let's say I'm on the bus, and I want to comment to a forum post using my IPhone. I click the link to said post, and enter my Applevis user information. it logs me in, and I comment. Then, I close Safari. Later, I want to log into Applevis to comment again, or just browse. However, when I do this, my user info is not remembered. I have to enter it all again. Not such a big deal if your not one who uses complex passwords. So, how do I get the Keychain to work correctly? yes, I have authorized it on both my phone, and my Mac. I'm just making sure that's covered. This is also the case with any other site I visit which requires user names and passwords. thanks in advance.

Hi. To turn on Keychain in iOS7 you go to Settings>iCloud and switch on Keychain in the list of services. Also go to Settings>Safari and select Passwords & Autofill and make sure Names and Passwords are switched to on too. On Mac it's in System Preferences>iCloud and press the Advanced button under the General tab. Now when you sign in to a website, a dialog box will ask you if you want to save the password to your keychain. I have found that sometimes it can take some time to sync across devices but it does work well for the most part for me anyway. If it isn't working on a particular website, it may be because you previously selected the option "Never for this website" in the dialog box. I haven't done this before so I'm not sure, but I'd imagine that if you look around in Safari's settings you may be able to change the status for that website. Some websites do request that you don't use keychain, but again you should get a dialog box when this happens. HTH

Thanks very much. That explains why it wasn't working. I didn't realize you had to tell Safari to cooperate.