Keyboard Access Broken in IOS 15

Forum
iOS and iPadOS

Hello, everyone. I updated my iPhone SE 2016 to IOS 15 when it was released, and I have been having nothing but problems ever since. I normally accomplish everything via my external qwerty keyboard and Orbit Writer. Usually, things are displayed in a linear fashion, from apps on the homescreen to the controls in various apps themselves. So I would start at the left and end at the right. Now, certain apps are all over the place. For instance, Voice Memos shows some recordings moving from left to right, but in order to go to others, or to hit the record button, I must hit the down arrow. The command for activating buttons has also changed. Usually, it's up and down arrows together. Now, some buttons respond to that and others must be activated with the space bar. This includes when the screen dims and says "press home to open". Sometimes, it doesn't work at all, and I must press the physical button on my phone. Some apps, such as weather, are now completely inaccessible with my qwerty keyboard, and Messages sometimes appears this way as well, though with some effort, , I can make it work. Sometimes, I am forced to use the touchscreen to access certain parts of apps before I can begin using my keyboard again.

For the most part,, none of this applies to my Orbit Writer, but whenever I use it, it seems to interfere with my WiFi when I am on Facetime calls. It makes it sound as if I am about to lose the connection, or as if the sound quality has dramatically decreased. This usually happens when the keyboard sleeps and when I wake the phone and keyboard. I also don't know how to write numbers and various symbols with the Orbit Writer so that they appear as such and not letters or contractions. I know how to write in Grade II braille, but I have only used it to access dialup Internet with my Braillenote in 2002, and entering mixed letters, numbers, and symbols in passwords and/or e-mail addresses seems to be different here.

Any help or suggestions would sincerely be appreciated.

Options

Comments

Submitted by Oliver Kennett on Wednesday, September 22, 2021

It's in your rotor settings under navigation style. I think you need to put it on 'flat'... As far as I can tell anyway.

Submitted by Yvonnezed on Thursday, September 23, 2021

Group navigation is kind of a learning experience for a lot of us right now. I have to admit I haven't even tried it with the keyboard yet. Admittedly that's mostly because I actually find navigation on an iPad with a keyboard incredibly annoying, so that's probably not surprising, ☺️

Submitted by Georgiana on Thursday, September 23, 2021

I just went to Focus, and there was no way for me to change the time of Do Not Disturb with my qwerty keyboard. It just said "dismiss popup" and nothing else. Even when I touched the screen, it didn't say anything. I had to use my Orbit Writer to click on the time and change it. Then, it opened properly and I was able to do so. I really wish I knew what was going on here, because it's truly frustrating.

Submitted by WellF on Thursday, September 23, 2021

Try disabling full keyboard access. It still causes some issues with voiceover, although in iOS15 they're not that bad. I can't navigate saphari though, and the keyboard navigation skips stuff, specially text.

Thank you. I will try it, but judging by the name, it sounds a bit counterintuitive, since I do everything with a physical keyboard. My keyboard never skipped anything in IOS 14. All of this started after the update.

Submitted by Georgiana on Friday, September 24, 2021

I just went to Apple Support to learn more about full keyboard access. Mine is currently turned on. In any case, the commands listed are completely different from the ones I learned from the same site. I was going to disable full keyboard access,but I received some kind of alert before doing so, and Voiceover won't read it. I just want to ensure that, should I do this, I will still be able to control my phone via the keyboard. Here is the page in question.

https://support.apple.com/guide/iphone/keyboards-ipha7c3927eb/ios

These are the commands that I learned.

https://support.apple.com/guide/iphone/use-voiceover-with-an-apple-exte…

Submitted by Nikola Jovic on Friday, September 24, 2021

Hello,
Basically, to make this as clear as possible, there are two ways to use an iOS device with an external keyboard.
First, through VoiceOver, and that is the second link for commands you have posted.
This is how many blind people do it, and it is probably the recommended way.
Second, though full keyboard access. This method is available regardless of VoiceOver, so it is what a sighted user would use if they wanted to navigate via. Keyboard.
Since VoiceOver already provides full keyboard support, we don’t really need this feature, although it might provide commands that some people might find useful.
Previously, and especially in iOS 14, there were conflicts with full keyboard access and VoiceOver working together.
In iOS 15, this was improved, but there are still some rough edges.
You can most certainly try disabling full keyboard access, and seeing if the situation improves.
Worst case, just enable it back on.

I have also noticed something in your post, you say you use both arrow keys together to activate a button and this doesn’t seem to be working.
I never tried that so can’t say, but have you tried instead using the VoiceOver command to activate an element, which is VoiceOver key plus space?
The VoiceOver key is either CTRL option, or the CapsLock key, depending on what you configured from VoiceOver settings.
Let me know if any additional help is needed and I’ll try my best as a keyboard user.

I sincerely thank you for that well-written explanation. I turned full keyboard access off, and this may have resolved my problem. I will need to experiment more to be certain. I will keep the command for activating buttons in mind, but for now, at least, the arrows seem to be working.

However, I now have another problem. I cannot send messages. I can get into a conversation and read what is there, but there is no edit box. This remains true whether I use my qwerty keyboard, my Orbit Writer, or even slide my finger around the screen. How can I resolve this? I have used the touchscreen when I had no other option, but only to locate and activate apps, buttons, and such, never to type. That would be a nightmare.

Finally, there are times when the screen seems to be stuck on battery percentage. NO matter which input method I use, I can't go to the home screen or anywhere else. The only solution I have found is to go to edit, then tell it to stop editing apps. Then, I am able to get to the home screen.

Submitted by Georgiana on Friday, September 24, 2021

I just received a message and was able to reply to it, but I couldn't read it. Then, something happened and I could read it and my reply, but I couldn't reply again. I have no idea what's going on.

Submitted by Georgiana on Friday, September 24, 2021

I can now definitively say that the keyboard problems have been resolved by turning off full keyboard access. All apps, aside from Messages, now work properly. I also deleted the Batteries widget from my homescreen. Now, I will need to find accessible substitutions for those two. I also downloaded IOS 14.8, in case I want to downgrade to that version, assuming that Itunes is accessible with NVDA.

Submitted by Ross Sydney on Wednesday, September 29, 2021

I also have a lot of issues with my Ipad Pro 12 inch 1st edition and upgrade of IOS 15. My Logitec K380 was intermittent in handling normal screen navigation, from moving from heading into text or list areas and more. In twitterific, it would not move into the active list of tweets.

So thank you all for your guidance. By turning off "Full keyboard control" in Accessibility - Keyboard settings, it seems I have a lot more control of the screen and content.

By the look of this forum however, IOS 15 appears to be a particularly flawed upgrade for people with Accessibility issues. AppleVis and J-Mosen have been advising Apple of these issues for some time and it is disappointing that Apple clearly have not taken heed. I will be keeping my SE2020 on 14.8 for some time to come.