Itunes is playing everyhthing in my library

Forum
iOS & iPadOS

Hi all. This has to do with iTunes. Right now it's playing every song i have in my library, even if I haven't downloaded it. I don't want that, is there a setting i need to change? I have a lot of stuff, I liked, now not interested in. Thanks for any help. both itunes on he mac and phone do the same behavior. Thanks all.

Options

Comments

Submitted by jcdjmac (not verified) on Tuesday, December 27, 2016

Hi,
I haven't had that problem. I cloud has an option that plays everything, even though it hasn't been downloaded. The option can be found in the music settings. I don't use my phone for music anymore, as I now use my iPod nano for music playback. HTH.

Submitted by jcdjmac (not verified) on Wednesday, December 28, 2016

oops. guess you'll need to ask around for other solutions.

Submitted by Roxann Pollard on Wednesday, December 28, 2016

When using the iPhone, I select the library tab, then choose playlists, artists, albums, etc., and then make a choice from there. Alternatively, Siri is very nice in accommodating for playing music. For example, if you have created a playlist, just activate Siri and ask it to play X playlist and it will do so. You can also ask Siri to play X artist or play the X album and it will. If you ask Siri to play music, then it will default to playing all tracks in your library.

HTH

Submitted by surya kumar on Wednesday, December 28, 2016

there are two options I hope
1.
Open iTunes.
Go to File > Library > Update iCloud Music Library.
2.
Open iTunes.
Select Music from the dropdown menu on the left side of the iTunes window, then select the Library tab and Songs under the left column.
Select all your music in Songs view (use Command-A on the keyboard).
Press the Delete key on your keyboard.
Click on the Delete Items option to remove these tracks from iCloud Music Library. (Do not, under any circumstances, click Remove Downloads — this will move all your local music to the trash, rather than delete songs from iCloud.)