Is it just me or is there a bug in the latest version of Fleksy?

Club AppleVis Member
Forum
iOS & iPadOS
This could just be me being really stupid but there seems to be a really annoying bug in the latest version of Fleksy Happy Typing that came out a couple of days ago. Sometimes quite randomly it seems and without me touching the screen it will start adding new line after new line. Worse it seems like it’s stuck on this function and will keep doing so until I press the screen to get it to stop. Worse still it might also just start deleting my text with out me pressing anything and again it seems like it’s stuck on this function and by the time I get it to stop most of my text is gone and I have to input it all in again. If I leave it, it just keeps on trying to delete text even when there’s nothing left to delete all with out me pressing a thing. I’m using it on an iPhone for with the latest iOS. Has anyone else noticed this or is there something really daft I’m doing? I’ve not had it for long but I don’t remember the last version having this problem. Any help would be great. Lou

Options

Comments

Submitted by flcomputergeek on Sunday, August 12, 2012

Yes. I noticed this yesterday, and it appears to have been introduced with the latest updates. Fleksy does seem to add new lines without me touching that part of the screen. At one point, I immediately swiped left to delete the new line character I didn't want, and fleksy got stuck in delete mode and erased everything I'd written. Having said this, I've been impressed with fleksy since the first day it was released, and I am very impressed with the latest update. It is nice not to have to toggle voiceover on and off, adding words to the dictionary now works more consistently, and most importantly, I now receive verbal typing feedback from fleksy while using it out of wi fi range. It worked very well for updating my work notes on the bus yesterday.

Submitted by Bill Fleksy Expert on Sunday, August 12, 2012

Hello Lou,

This is Bill from the Fleksy team. We really want to squash this bug so any more information you might have on it would be really helpful. For example, what is going on with your iPhone when the new line or delete gesture get stuck? Does it still happen if you put your device on a table?

Transitioning to the Direct Touch implementation is new territory, although we have tested extensively internally and with our beta testers. Feel free to contact us at support@fleksy.com with any questions or information on this or other bugs. Thank you so much for being an awesome community.

Submitted by Chelsea on Sunday, August 12, 2012

In reply to by Bill Fleksy Expert

Hi Lou and Bill, I think I am having the same, if not related, bug. I am on the beta team and have reported it, but I'll just restate so others don't feel alone. For me, this seems to happen when I get a notification, like a text message. Interestingly, after using Fleksy for a couple of days, it doesn't happen on every incoming text. I find it very difficult to replicate, but I think it has something to do with when you're entering manual words. Hope I'm leading you down the right path. I've tried to be as specific as possible, but let me know if you need more info. Thanks for all your hard work, Chelsea

Submitted by Lou on Wednesday, August 15, 2012

Club AppleVis Member

In reply to by Chelsea

Hi Sorry to take so long getting back to you. I wanted to monitor my use of fleksy a bit before replying so I had more of an idea of when the bug occurs. Firstly it doesn’t seem to make any difference on weather I receive other notifications or not. None of the times this bug occurs has been when I’ve received a notification. Oddly enough it doesn’t seem to happen when the phone is flat on the table but I find it really difficult to type that way. when I’m using fleksy I tend to be holding the phone in portrait mode in front of me in both hands with the phone slightly tilted upwards. I tend to do all my typing with my thumbs. I have small hands and I don’t know if this is how other people type but it seems easiest for me. The bug often occurs either just after I’ve just manually typed in a word or attempting to manually type in a word. It usually gets stuck in newline mode and will keep adding new lines on it’s own but if you swipe left in an attempt to delete the new lines it will then get stuck in the opposite direction and start deleting not only all the new lines but all the text before hand. Sometimes it gets stuck in delete mode when I’m manually typing a word as well but mostly its new line mode. However in every case when it’s stuck in new line mode if you swipe left to delete the new lines it will invariably get stuck in delete mode instead. If you just tap the middle of the screen it will unstick the new line mode but with out it deleting all your text instead. The times when it’s harder to know what’s going on is when it will get stuck in new line mode with out me even touching the screen. It’s almost as though it’s detecting the presence of my right thumb even though it’s not actually touching the screen. That’s the only explanation I have for it. I’m not sure if any of this makes any sense but if you need any more info just let me know and I’ll see what I can do. Thanks again Lou


Thank you Lou, this was an incredibly useful and insightful description.

I may have reached the same conclusion as you:

What happened, most likely according to your description, is you inadvertently had a finger(or even part of your palm) on the screen while holding the iPhone. The way the swipe and hold gestures work is by merging the two separate gestures, the swipe and the hold. This means that it doesn't have to be the same finger that does the swiping, the one that has to hold. The reason this is not reported by many users and not addressed by us this whole time is because there are few users that hold the iPhone and type like you do. I personally think it is the most convenient way to type too, but must have been luckier with the way my palms cradle the phone. 

To confirm, type like normal and if it is stuck again, lay your iPhone on a table to see what happens when nothing is close to the screen. It should stop entering new lines.

This is obviously a matter we will look further into. Thanks so much!

Regards,

Bill 

Fleksy Expert

Submitted by kieran l on Friday, August 17, 2012

In reply to by Chelsea

Hi, I've been using the newest virsion of fleksy for about a week now and haven't noticed any bugs. Could it be a device specific issue? I don't know why, but it could be a possibility. I'm using an iPhone 4S, if that helps.