iOS Notes lock hint - is this a bug?

Forum
iOS & iPadOS

Hello everyone on Applevis,

This is my first post (though I've been a very long-time lurker), so before I get to the subject, I'd like to thank you all for all the information you've been providing. This is a wonderful resource - I think I'm an advanced iOS user but I'm not sure I could have been one without Applevis.

And now on to my question:

I'm using iOS 11.4 with VoiceOver. In the iOS Notes app we can lock our notes with a password: one password for all the notes. When we set that password (in the app itself, or in settings > Notes), we have two fields for the password(as usual) and one for a hint - a reminder that is to help us if we forget our password. We can enter that hint without a problem.

If you try to unlock a locked note and forget your password (or deliberately give the wrong one), then in theory you can see your hint on the screen. However, VoiceOver doesn't seem to be able to find and read this hint. I made a screenshot and sent it to Seeing AI and it read the hint: but no matter what I tried, I couldn't locate it with VoiceOver in the Notes app itself (it just says that the password is incorrect and prompts us to try again)... Or am I missing something?

I hope I am . But if you can reproduce this, let's report it to Apple so that it could be squashed in iOS 12. Fortunately I ran into this by accident, but I can imagine some situations where this could be very unpleasant. (And I do know there is touch ID, but there are scenarios where that's not helpful: for instance if you have notes locked with an old password and now you're using a new password.)

For those who haven't tried it yet: you can find the "lock" button in the Notes app, under "share".

thanks!

Options

Comments