iOS 13.1 still won't allow me to change VO audio destination for bluetooth?

Forum
iOS & iPadOS

Hi guys
Do you know if there's a way in iOS 13.1 that would make voiceover speak on iphone speaker or headphones while the phone is streaming to a bluetooth device?
It's 2019 I am absolutely frustrated that i still can't do this.

Options

Comments

Submitted by Hadi on Wednesday, September 25, 2019

Just to clarify, i'm on iPhone 6s. I connect to a bluetooth speaker, and when i go through my router i do not see the audio destination option. It just does not come up.

Submitted by HEXAGON on Thursday, September 26, 2019

I can't set the audio destination since iOS 12. The rotor "audio destination" don't appear if I have connected a bluetooth device.

Submitted by sockhopsinger on Thursday, September 26, 2019

it won't appear unless you go into settings, accessibility, Voiceover, roter, and scroll down the options to find audio routing . You have to double tap that and make sure it is selected before it will appear when you change your roter.

Submitted by Hadi on Thursday, September 26, 2019

I have already selected audio destination in there.
but i don't have any audio routing in my VO settings

Submitted by sockhopsinger on Thursday, September 26, 2019

Sorry I was not sure on that.

Submitted by KE7ZUM on Thursday, September 26, 2019

I think it actualy is. In fact I read somewhare about audio sharing. I never have gotten the autio dest to work ever since ios 10 in 2016. So you are not alone.

Submitted by flcomputergeek on Friday, September 27, 2019

I experienced this phenomenon for the first time this morning. Voiceover was speaking through my Bluetooth earbuds, and the instant I opened amazon music, VO switched to the internal speaker. This would be great if I were using an external Bluetooth speaker, but with headphones on, I either couldn't hear VO or had to raise the volume which would have disrupted my driver. I've tried many of the suggestions in this thread and others. I do have audio destination enabled in the rotor but it does not appear as an option in situations when VO switches from my earbuds to the internal speaker. I looked in many places in settings and did not find an audio routing option aside from the speaker phone option. My perspective is that this feature should have a setting, so I could choose whether I want VO to come through the internal speaker or the headphones based on the situation.

Submitted by Oliver Kennett on Friday, September 27, 2019

This only works on Apple TV with airplay. It doesn't apply to bluetooth.

Submitted by Chris on Friday, September 27, 2019

Oliver is correct about AirPlay. However, I can't seem to get that to work anymore in iOS 13.1 with Shairport-Sync on a Raspberry Pi. The audio destination option does not appear at all even if it is selected in the rotor.

I've wanted Apple to use this to choose where VoiceOver audio goes, but it seems like this is either ignored or not high on the priority list of things to do. It would be wonderful to use this to specify whether VoiceOver goes through the default speaker on the device or your connected audio source via Bluetooth, AirPlay, or the 3.5mm audio jack/lightning audio adapter.

Submitted by Oliver Kennett on Friday, September 27, 2019

I think its actually for video so this is why it is tied to the Apple Tv if you're mirroring on there I think you can put VO back on your phone. I don't believe it applies to just audio. I'll have a play later.

O

Submitted by Bobcat on Tuesday, January 28, 2020

I just updated from 12.4 to 13.3 and I am very disappointed about this audio routing of voiceover without any control over it. By the way this is also a problem with Siri as it wants to use the speakerphone microphone.
I do have audio destination turned on in the rotor but it never appears when I turn on the Bluetooth speaker.
Another problem I have is that sometimes my speech rate and pitch go away up as if it was open fast forward when I first turn on the Bluetooth speaker. I have to invoke Siri which will then try to use the microphone in the speaker which I don’t want then when I dismiss Siri the speech rate goes back to normal. Is this discussed another form or thread? This really needs to be addressed. I am planning to call Apple Accessibility but just want to find out more here first.

Submitted by HEXAGON on Tuesday, January 28, 2020

I‘m still encountering the same problem. It doesn‘t work sinsce iOS 11 or so and it seems that it never gonna gets fixed.

Submitted by Kevan on Tuesday, February 4, 2020

Different speakers have different results with iOS 13. They either play VoiceOver audio, or force it back to the phone and play only music themselves.
I don't know if it's possible to change the setting, and only 1 of my speakers plays only music while leaving VO to come out of the phone itself. While this is happening I cannot adjust volume on the phone's speaker for VoiceOver, but I can adjust the external speaker's music volume with the volume buttons.

Submitted by Tina on Wednesday, February 5, 2020

I've noticed this problem on iOS 13.3, and I'm not sure if it's a bug in the system or something else. To me, it's a bit strange, especially since some of my speakers play voth VO and the audio from the speaker, while some will play audio from the speaker while VO comes through the phone.

I do like it if you don't want everyone in the room to hear Voiceover, but I think there does need to be an option in the settings based on each speaker. I had an Apple expert test it, and he got the same odd behavior with an Amazon speaker.

So has anyone thought of contacting Apple about this? Thanks.

Submitted by Oliver Kennett on Wednesday, February 5, 2020

I think that IOS has to identify the speaker as a speaker for VoiceOver to remain on the phone whilst audio is routed through the speaker. Some speakers come up as headphones meaning that IOS routes everything to them because they have microphones built in. Check in control centre under available routes and see if your speaker comes up under the speaker heading or as headphones.

When using iPhone connected to an echo, for example, VoiceOver will remain on the phone whilst the audio goes through the speaker.

Submitted by Luke on Thursday, February 6, 2020

I was always annoyed in the past that VoiceOver output would always go to whatever speaker I connected to. If I have a few friends over and am trying to stream some music on our living room sound bar, for example, I don't want VoiceOver blasting into the room.
So, I was actually excited to find that now iOS seems to be smarter about this. When I'm using my AirPods, VO consistently plays through them along with other audio, as expected. I have two Bose speakers, a small Sound Link and the aforementioned sound bar, the Bose SoundTouch. In both cases, VO output remains on my phone's speaker while the streamed audio goes to the speaker, again, the desired behavior.

It sounds like maybe I've just gotten lucky, as not everyone is having such consistent results. Maybe this means Bose speakers seem to play especially nice with this new "feature"?

Either way, they really need to give us users the ultimate authority to decide where VO output is routed. Why is that not an option yet? Seems silly in 2020.