how do I get Voice over to read an apple book in English when the book is using something that appears to be a German script

Forum
iOS & iPadOS

I recently purchased an Apple book on the Books app. I tried reading it with voiceover in the app and it wanted to read the book to me in German. The book is in English. I went to accessibility and voiceover and speech and turned the setting for detective languages to off and it still wants to switch to German whenever I read this book. The interesting thing is it reads the table of contents in English and it reads the cover information. It reads the text in German. I checked throughout the book and it still continues to do thisDoes anyone have any ideas on how to make voice over read it to me in English. I don't think I can transfer it to other apps I've tried a couple of them but since this is an Apple book it appears to be limited to only reading in the Apple Books app. Any ideas would be appreciated. Thank you.

Options

Comments

Submitted by zeirus-fr on Wednesday, April 21, 2021

Hi.
I advice you to change the interface localization into English.
As I think you have purchase the book in epub format.
Maybe there are incorrectly located attributes "lang" in this file.
The epub file, as i know, is a zip file with xhtml format with extra information.
It's supposed the book will be read in usual way with no voiceover.
Therefore, you shhould correct the xhtml tags with attribute "lang" accordingly.
Or you have to change your localization into English temporarily.
Maybe, I am wrong. Good luck.

Submitted by Maldalain on Wednesday, April 21, 2021

There is a workaround for this. Add English voice to the router speech option in VoiceOver and use the rotor to navigate to language then use the down arrow to switch to the newly added English voice. This way VoiceOver won’t detect German language of your document.
HTH

Submitted by Shelley on Thursday, April 22, 2021

Thanks for the information everyone. I got the book to read in English. :-) Now if I could just read the rest of my Apple books :-) they’re all in English although now there are some German ones to that’s why it was confusing to me. Glad the fix was so simple. :-)