contractions in iOS12's text to speech

Forum
iOS & iPadOS

Has anyone else noticed a major downgrade in how iOS12 handles contractions and other punctuation in text to speech? I use this feature extensively and noticed right away that it frequently pronounces contractions oddly. "That's" becomes "That S" and anything written with a possessive apostrophes gets similar treatment.

I'm hearing this in Speak Screen, VoiceOver, and Speak Selection. It's even showing up in the word app when I use it's built-in text to speech (that feature uses iOS's speech engine). I bring that last part up because that app reads back in various accents if the word doc has language tags set. The pronunciation issues show up in Aussie, UK, and American English, so I don't think this is an issue with the voices themselves. I noticed the problem as soon as I upgraded my old iPhone to iOS12. The problem showed up again when I got my new phone with iOS12 preinstalled. I haven't updated my iPad to see if the issue gets replicated there because I'd like at least one device that still works properly.

I've tried to pin down when it happens. It's a most of the time but now always kind of deal. There is consistency on what gets messed up, but I can't figure out the exact word context that triggers it. Has anyone else noticed this?

Options

Comments

Submitted by Dawn 👩🏻‍🦯 on Saturday, October 6, 2018

This problem with regards to Vo. has been around since I've had my ipad. And I've used Ios. 9. And as far as I know, it's been around before that. No matter what service you use. As for Word, I can't say, because I use Vo.

Submitted by colorblindpicaso on Saturday, October 6, 2018

Interesting. Something definitely triggered it for me during the update because I use it daily and only noticed it after. If it's the same issue, I wonder if it's a setting or 3rd party app install we've got in common. It's distracting enough that I expected to find lots of mentions on google, but I haven't.

Submitted by Kate on Sunday, October 7, 2018

YES! It’s so annoying! I have an iPad Pro 10.5” and the issue only started after I installed iOS 12. I even tried to override it with the Pronunciation feature and it still did it. I hope it gets fixed soon. Have you tried a third party app? I’m thinking of trying that next.

Submitted by Shersey on Monday, October 8, 2018

This seems to be happening with me, too, but I think it's only happening when the character used for the apostrophe is a single quote. VoiceOver says single quote, not apostrophe. It's so weird, and makes it rather hard to read by voice alone!

Thanks,
Shersey

Submitted by Carlos on Thursday, October 18, 2018

Not with contractions or quotes or apostrophes but with long dashes (—), they all sound as “r”. And, yes, it all started with ios 12. I’m testing ios 12.1 beta 4 and the bug is still there.
I use Marvin 3 for reading books and blamed the app, but then a realized it’s on the ios itself. Very annoying!