Can't work out what is using my data

Forum
iOS & iPadOS
Hello, The other day I unlocked my iPhone and noticed the "network connection in progress" icon was there inbetween the 3G/wifi indicator and the time, meaning something is using the internet. As it was on the home screen, I couldn't figure out what it was. I checked the settings in the "background app refresh" and they were all as I wanted them, and none of them appeared to be using my internet. Next, I closed all my apps from the app switcher, then went back to the home screen. The icon was still there. I thought I'd leave it for a bit and give whatever it was chance to shut down, and it was still there after about 5 minutes. The only way to get rid of it was to reboot my phone, which fixed it and I thought it must have been some sort of glitch. But then the icon appeared again today, I did exactly the same thigns again and only thing that worked was rebooting my phone. I'm starting to get a bit worried though as I can't work out whether it's a bug or something is using the network connection, therefore using my data allouence without me realising. Anyone else having this or know of a way I could figure out what might be causing it? Thanks, Callum

Options

Comments

Submitted by Karl on Friday, April 4, 2014

It could be apps automatically updating, an app downloading something, your phone checking email, etc. Do you have a podcast or similar app on your phone? It may be refreshing feeds. One thing you can do is go into settings/cellular, and you can see which apps have used cellular data and how much. What you can do is reset the statistics with the button at the bottom of that screen, and then check back after a day or two to see what is accessing data.

Submitted by Lisa on Friday, April 4, 2014

Weird question, but before each of these occasions, did you happen to use dictation? There seems to be a bug where when you use dictation, it seems to stay active, even if you lock your phone. The only thing that cures this is either rebooting the phone, or playing a sound, such as holding down the home button to activate the siri sound. Siri doesn't cause this problem though, it's isolated to dictation.

Submitted by Callum on Friday, April 4, 2014

I've reset my statistics on the usage screen and I'll see if that makes any difference. As for dictation, I couldn't tell you whether I was using it before this happens as I use dictation a lot. I'll keep checking when I use it. Thanks both.

More Like This