Can't update to 9.3

Forum
iOS and iPadOS

Can't update to 9.3.
On my iPhone:
Because it says it is no longer connected to the internet when it actually is.
In iTunes:
because it says 9.2.1 is the most recent version.
This after updating iTunes today.
I guess I don't want to update.
I don't want to phone Apple support because I know they will ask me to reset my network settings at the minimum. I don't want to have to look for my passwords and keys again!
It all seems like to much trouble for an update that hardly fixes any accessibility bugs.

Options

Comments

Submitted by Toonhead on Saturday, March 26, 2016

Have you tried over-the-air updates? settings/general/software update. Make sure your phone is plugged in and make sure Wi-Fi is enabled. If it doesn't show up try rebooting your phone. This is what apple is calling a regional update so you may have to wait, but I suspect most people have it now. Also the only thing that's required are your apple ID and password. Not sure what you mean by keys?

Submitted by David on Saturday, March 26, 2016

As I posted in the article about 9.3 being released, I too am having this problem. As explained there, I have tried both over the air and via ITunes updates.

I did find a way to delete the update from my IPhone, as it had been downloaded but wouldn't install. Now, both my IPhone 5S and ITunes say that 9.2.1 is the latest version. IPhone still shows 1 update available, but when you go into Software Updates, it says 9.2.1 is the latest.

someone said that the fix for the problem that caused Apple to withdraw 9.3 for older devices had been released. But both my IPhone and ITunes are behaving as if 9.3 is still not available.

Submitted by Ohad on Saturday, March 26, 2016

apple has withdrawn the update for older devices because it caused some problems, that's what I read somewhere yesterday. according to what I understood, apple will release a fixed version of the update within a few days. I read this a few hours ago so I don't believe the fix is already available.

Submitted by Bobcat on Monday, March 28, 2016

I looked at the articles about the delay in the update. Thanks for that information. I have a 5S so I might've really got stuck for a while. I think I will wait a while longer to update.

Submitted by Hey-June on Tuesday, March 29, 2016

If you've had this problem and like me keep getting asked to install the update, here's how to make it stop:
1. Go to Settings and then General
2. Go into "Storage and icloud usage"
3. Swipe right until you come to the button "Manage Storage" and click on it.
4. Swipe right until you hear "Software update" and click on it.
5. Swipe to the delete button and click on it. And then confirm.
Done.
4.

Submitted by Fiona on Wednesday, March 30, 2016

I met the same problem. When I first try updating iPhone 6s Plus to iOS 9.3 from iOS 9.0.2, I check for updates with iTunes, and it says iOS 9.2.1 is the latest version. Then I check the update again and it says iOS 9.3 is available. It only takes me about 15 mins to update to iOS 9.3 with iTunes on Mac mini.

Submitted by David on Wednesday, March 30, 2016

The older device fix has now been released here in the UK. I checked for updates in ITunes last night and 9.3 was available again. A huge 1.8Gb download, which was disappointing because I thought IOS 9 was supposed to reduce the size of updates, but at least it's done now.

Also updated my watch to 2.2, although it seems a little more sluggish since. Initially VoiceOver wasn't speaking the focus in new screens or the clock face, but powering off and on again has sorted that. Always a good idea to do that with the watch at least after an update, and possibly even the phone.

Submitted by Ann on Saturday, July 30, 2016

I am having this exact same issue trying to update to 9.3.3. I am connected to the internet. The phone is plugged in. I have plenty of space and have tried both over the air updates as well as using iTunes.

I've rebooted the phone. I've deleted the update and tried to re-install more times than I can remember.

Anyone have any suggestions?

Mostly, restoring iPhone from a previous backup will solve the problem. You can firstly back up your iPhone with iTunes. And then click Restore iPhone, during the process, iTunes will automatically update your iPhone to the latest version of iOS.